• Status: Solved
  • Priority: Low
  • Security: Public
  • Views: 174
  • Last Modified:

Whitelist Top Level Domain - Exchange 2016

I can set a transport rule to BLOCK top level domain, but not whitelist them.

Is the correct syntax "Set-ContentFilterConfig -BypassedSenderDomains @{Add="*.gov"}" or is there something more?
0
RISLA
Asked:
RISLA
  • 2
1 Solution
 
Jose Gabriel Ortega CEE Solution Guide - CEO Faru Bonon ITCommented:
To whitelist it, you just need to run this

Set-ContentFilterConfig -BypassedSenderDomains domainA.com,domainB.com,domainC.com, ... , domainZ.com

Open in new window


To Block:
just need to enable the content filtering, automatically all the domains will be checked except those that are set in the command above.

https://technet.microsoft.com/en-us/library/aa995953%28v=exchg.160%29.aspx?f=255&MSPPError=-2147217396

What I do is to save all the line within a text file so that I can add or remove there, each time you call the Set-ContentFilterConfig cmdlet will rewrite the previous, so you need to keep track of the changes.
0
 
RISLAAuthor Commented:
I'm trying to whitelist .edu and .gov TLD
0
 
Jose Gabriel Ortega CEE Solution Guide - CEO Faru Bonon ITCommented:
Sadly it Just works on individuals domains so on the fly you need to go domain by domain, there's no option for the root domains
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now