• Status: Solved
  • Priority: Low
  • Security: Public
  • Views: 94
  • Last Modified:

Weird message shows in Explorer "This content can’t be shown in a frame"

I have a website, when I go to it. I keep getting a weird message. It only shows in Explorer.  

No message in chrome.  Just a blank space.

http://www.positiveglobalnetwork.info


Its is saying:
This content can’t be shown in a frame
There is supposed to be some content here, but the publisher doesn’t allow it to be displayed in a frame. This is to help protect the security of any information you might enter into this site.
0
Nicole Johnson
Asked:
Nicole Johnson
  • 2
2 Solutions
 
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Likely fix...

1) Set a DOCTYPE.

2) Keep in mind, the following is the only valid DOCTYPE for a frameset based page...

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
       "http://www.w3.org/TR/html4/frameset.dtd">

Open in new window


3) Frameset has been deprecated for years. Likely most browsers will render this correctly with a correct DOCTYPE set.

Without a DOCTYPE set, likely most browsers won't render your page.

4) My guess is some mobile devices won't even try to render this old school HTML at all, even with a correct DOCTYPE.

I'd suggest you switch to using HTML5.

With HTM5, you'd use something like...

<object data="foo.html" type="text/html"><p>Fallback message!</p></object>

Open in new window


Likely you can turn up some online guides which cover all the gory detail of updating to HTML5.
0
 
Paul MacDonaldDirector, Information SystemsCommented:
99% sure it's because your SSL certificate doesn't match the name "positiveglobalnetwork.info".  You might consider a SAN SSL certificate to replace the one you're (or your host) using from GoDaddy.
0
 
Lucas BishopClick TrackerCommented:
You're attempting to load the following secure page:
https://shop.totallifechanges.com/nsanders

Inside of the unsecured page here:
http://www.positiveglobalnetwork.info/

The totallifechanges.com domain doesn't allow their site to be loaded in a frame:
Refused to display 'https://shop.totallifechanges.com/nsanders' in a frame because it set 'X-Frame-Options' to 'sameorigin'.

Specifically they are using x-frame-options = "SAMEORIGIN" which specifies:
The page can only be displayed in a frame on the same origin as the page itself.

You'll likely need to setup a redirect from your site, to theirs.

That way you can give people your domain name (for marketing) and it will send them to the appropriate 3rd party site (for your affiliate reward).
0
 
Paul MacDonaldDirector, Information SystemsCommented:
Likely solution(s)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The Lifecycle Approach to Managing Security Policy

Managing application connectivity and security policies can be achieved more effectively when following a framework that automates repeatable processes and ensures that the right activities are performed in the right order.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now