Exchange 2007 migration to 2013 -coexistence- OOF settings are not available from Outlook client connected externally

Hi Guys,

We are in the middle of mailbox migration between Ex2007 to Ex2013 so now we have both Exchange server's present. It appeard that users cannot set OOF messages when they are connected outside of the company. Inside company network and through OWA they can do it without any erros, but externally they're receiving "Your automatic reply settings cannot be displayed..."

Before the migration we didn't had autodiscover entry, and everything worked well, so what happened that now we have lost access to set OOF ?

 when I type https://webmail.xxx.com/ews/exchange.asmx I'm receiving note that "You have created a service." and this stands for Exchange 2013 url . When I type https://legacy.xxx.com/ews/exchange.asmx and enter credential I am receiving also xml page so I assume that's correct ?.

On both Ex2013 and Ex2007 for Ews were updated in the following way:

Ex CAS 2007 internal and external URL points to https://legacy.xxx.com/ews/exchange.asmx
Ex CAS 2013 internl and external URL points to https://webmail.xxx.com/ews/exchange.asmx
Rob ThortonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MaheshArchitectCommented:
Can you check if your exchange 2007 users are able to get OOF settings?
what about remote domains? are you able to see remote domains in Exchange 2013 console
OOF is the functionality provided by remote domains
0
Rob ThortonAuthor Commented:
Either users which mailboxes are on Exchange 2007 and 2013 cannot set OOF when they are offsite, without access to corporate network. Internally inside corporate network OOF works fine, even OOF in OWA works fine.

In PS i can see
Get-RemoteDomain command
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rob ThortonAuthor Commented:
Hi,
We added entry autodiscover.domain.com in public Dns and OOF started to work
0
Ajit SinghCommented:
Glad to hear its working. Please close the thread so other can get help from this.
0
Rob ThortonAuthor Commented:
Thank you all for your efforts.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Chat / IM

From novice to tech pro — start learning today.