Hyperlinks are not opening after setting a GPO with an approved list. What am I missing?

We have set a list of applications through GPO that will be the only ones that an end user will be able to access. This was set in GPeditor in User configuration / Administrative Templates / System / Run only specified Windows applications.

Everything was set and its working as expected. Unfortunately, hyperlink will not open.

- The error reads: Your organization's policies are preventing us from completing this actions for you.

- Example of the error: If you receive an email with a hyperlink and you try to open it, you will get that error message. The address where the hyperlinks are pointing to are within the approved list.

My best guess is that we would need to add an application (or service) that may allow hyperlinks to work but I just cant find it.

I appreciate any ideas or suggestions on how we can get this to work once again.
PiedraCellDepot EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeff GloverSr. Systems AdministratorCommented:
Did you add iexplore.exe or whatever you want your default browser to be as an approved application?
0
David Johnson, CD, MVPOwnerCommented:
perhaps he just stated the url i.e. http://www.example.com/*

My thinking is that he is using the wrong tool for this.  The blocking should be at the network level not the application level.  Depending upon the budget something as basic as Net Nanny might be sufficient.
0
PiedraCellDepot EngineerAuthor Commented:
Yes. iexplore.exe, firefox.exe and chrome.exe are currently on the list. The default search engine is Chrome.
0
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

PiedraCellDepot EngineerAuthor Commented:
Hello David,

We have been using a group policy to make this happen. We tried creating the policy from the GPeditor and even from registry keys since its for a school's IT room. Both ways have worked successfully allowing the applications listed on all ~20 computers but unfortunately it is blocking  for the ability to open hyperlinks.

Besides purchasing or installing another software, would there be any chance we can make it work with a GPO?
0
David Johnson, CD, MVPOwnerCommented:
A hyperlink is NOT repeat NOT an application it is simply a parameter to open a location using an application (the users default browser) i.e. if you disable Microsoft Word and click on a ABC.DOCX file even if you allow ABC.DOCX it will fail.

So you need something that works at the network level i.e. a proxy Like NetNanny that disallows or blocks the browser from using DNS to get the sites ip address
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PiedraCellDepot EngineerAuthor Commented:
Thank you David. Yes, I understand that it we disable word and receive a hyperlink that point out to work, it will fail. The issue here is that all hyperlinks are pointing to applications that are currently on the approved list. ie: you receive an email with a hyperlink to Microsoft Word. WHen you open it, it appears as blocked. (Note that Microsoft Word is in the approved list so it should open).

I understand your point on the NetNanny but at this moment, it is not an option to make this purchase so we need to use GPOs. It actually working but the hyperlinks have been "disabled" and we're trying to figure out what could be going on.
0
Jeff GloverSr. Systems AdministratorCommented:
Guess I lost the train there. You are saying that Hyperlinks, such as Web addresses, are broken. Are you able to open attachments in Outlook?
0
PiedraCellDepot EngineerAuthor Commented:
Hello lvjeff,

Let me recap:

We have a list of approved applications that we want some users to be able to access. These applications include Word, OneNote, Chrome, Firefox, Outlook, etc. The GPO we set for this to happen works perfectly and the users are only able to access the applications in that list.
The issue comes after setting that GPO on which I explain next:

Lets say youhave received an email with a word document. You open the document successfully and realize that the documentation contains a link that you need to access. Lets call that link www.bing.com. If you try to open that hyperlink, it gives you the error message:

Your organization's policies are preventing us from completing this actions for you.

The hyperlinks are all pointing to an internet address. As part of the approved list of applications, we have added iexplore.exe, google.exe, firefox.exe but we still get that error.
0
PiedraCellDepot EngineerAuthor Commented:
Unfortunately, this case was not resolved 100%.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
hyperlinks

From novice to tech pro — start learning today.