Why do I only get sound from the left and right front speakers?

DoctorK12008
DoctorK12008 used Ask the Experts™
on
I have a Creative Sound Blaster Z sound card connected to a Logitech 5.1 analog speaker system.   I can only get sound front he right and left front speakers.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2016

Commented:
go to your sound settings in windows and ensure that all speakers are enabled and do the sound test.  Afterwards you need 5.1 sound source to get 5.1 sound.
RaminTechnical Advisor

Commented:
You need to connect your speakers to Line out 1 through line out 3 and make sure Surround mode is selected from sound blaster settings.
You also may need to disable onboard sound.

1.jpg3.jpg

Author

Commented:
When I do the sound test in Windows, it appears to test all speakers, but sound only comes from the front speakers.   Not sure how to disable onboard sound.   Is it disables in Setup?   I have set up the Sound Blaster software per Ramin's illustration.   When I test the speakers it appears to test all, as  in Windows, but sound only comes from the front speakers.

Does it matter whether I use the optical connection versus the 6 connection?   I have tried both, with the same result.
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

RaminTechnical Advisor

Commented:
If your connections are the same with below picture then you have to Enable DTS / Dolby surround from your Settings. it needs a software setting.

2.png

Author

Commented:
When I try to enable DST or Dolby I get this message:

Sound Blaster Z-Series Control Panel
The SPDIF-Out (Sound Blaster Z) device is being used by another application.   Please close any applications that may be playing audio to this device and try again.

I do not know of any other application that may be using this.   What should I look for?
RaminTechnical Advisor

Commented:
Check your BIOS for onboard Sound and Disable it.

Or uninstall sound blaster Software and driver, Restart the PC and reinstall the software and driver.

Author

Commented:
I disabled Sound in the BIOS, it did not help.   I will uninstall the Sound Blaster software.   Do I need to physically remove the sound card as well?
RaminTechnical Advisor

Commented:
Just to be sure you can re-seat it. but it's not necessary.

Author

Commented:
I re-seated the card.   Still only sound from front speakers.

Author

Commented:
In Windows Sound, there are two items, Speakers Sound Blaster Z Ready and SPDIF-Out Sound Blaster Z Default Device.
Technical Advisor
Commented:
Try both of them,  you need to check all Windows Sound settings and also Creative software setting and check if that helps..
Top Expert 2016
Commented:
check your configuruationcheck your configuruation
RaminTechnical Advisor

Commented:
Thanks,  and I'm glad we could help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial