IPv6 127.0.0.1 ping result

I am having a new problem where the machines on my network are having DNS issues. When I ping certain servers for a desktop the result is always 127.0.0.1. The only way to get things working again is to disable IPv6.  We are running a Windows Server 2012 Domain controller with DNS Server. Nothing has been changed recently either. I have tried everything I can find on Google and am now stuck.
Gavin PittManaging DirectorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
127.0.0.1 is not an IPv6 address at all  under any circumstances. You have something else going on. Disabling IPv6 is a total red herring. Since you say it happens when you ping server names  that points to DNS. Host files  bad DNS server  poison cache...
0
IndyrbCommented:
when you ping you can use the -4 or -6 depending on what you want to force ipv4 = -4 ipv6 = -6
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Daniel Van Der WerkenIndependent ConsultantCommented:
Could be possible that you have a hosts file on your local system that is redirecting your lookups to the local host.

Hosts file location:
C:\Windows\System32\drivers\etc\hosts

Check for items like this:
127.0.0.1       thesiteyourepinging
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Tom CieslikIT EngineerCommented:
Go to Microsoft website and download a FIX to set Prefering for IPv4 over IPv6

Install it and after restart this will fix your problem

https://support.microsoft.com/en-us/help/929852/how-to-disable-ipv6-or-its-components-in-windows
0
masnrockCommented:
Try Tom's suggestion. What's happening is that your server is doing IPv6 DNS lookups ahead of IPv4 ones.
0
Gavin PittManaging DirectorAuthor Commented:
Hi Guys, managed to get it working again by flushing dns etc and rebooting all equipment and servers last night. I still have no idea what was causing the problem though.
0
Tom CieslikIT EngineerCommented:
I've sent you a fix but you don;t want to use it
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.