Outlook / Exchange Online / Office 365 auto discover

Hi All.

Here is an odd one.

Have an Office365 tenant.  Have created a mailbox on Office 365 directly (in cloud mailbox).

Office 365 testing shows all DNS records are Green - all entries as Microsoft requires, including autodiscover.

If I go to Office 365 webmail, i can access the new mailbox perfectly.  mailflow is fine.

If i start Outlook 2016 (which is fully patched etc), it fails.
- Establish network connection - fine
- Search for test.user@domain.co.uk - fine
- Then it pops up a login box, but Outlook is seeing this as an Internet email account

See screenshots.

I know the DNS settings are correct and I know the user/pass is correct (webmail test)

Have tried this on multiple different machines.  To no avail.  Both on the domain and not.

Here is the kicker...  Up until a few days ago, all working fine.

Pointers anyone?

Cheers,


Jamie
Capture1.PNG
Capture2.PNG
JamieD71Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jose Gabriel Ortega CastroCEOCommented:
Try it in here:
https://testconnectivity.microsoft.com/  (this will do the test externally)

And check your DNS settings, I know you said that they were right, but double check the record for autodiscover.

Also, you can open outlook then go to the "outlook icon" next to the time, press ctrl+right click and select the "autodiscover test" you can use that one too. (this will do the test internally or externally, depending on the location of the computer, this is o365 so will do the same test as the connectivity analyzer).
jose
0
CompProbSolvCommented:
The screenshots don't show the "Internet email" designation.

When you type in the correct password, what happens?
0
JamieD71Author Commented:
Have run the test connectivity used the Office 365 "outlook connectivity" option.  It failed.  Everything green in the report except this at the bottom
Capture3.PNG
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

JamieD71Author Commented:
But if I run the Office 365 "Autodiscovery" test, then it's green (OK, haven't expanded it)

Capture4.PNG
0
Tom CieslikIT EngineerCommented:
Check local DNS you try to setup outlook from

run CMD as Administrator

type nslookup

set typ=MX
yourdomein.co.uk

then set type-TXT
yourdomain.co.uk

Double check if all settings are correct and your DNS is see your External DNS setting for your email server correctly
0
JamieD71Author Commented:
Hi Tom.

Carried out the NSLookup tests and all as expected.  Also did a test of another domain on another tenant and that matches too.

Thank you


Jamie
0
Jose Gabriel Ortega CastroCEOCommented:
So the external face is working.

Use outlook and post the log tab. (CTRL+right click the outlook icon next to the time) and select autodiscover configuration.

Add the user information en post the log tab content.
0
JamieD71Author Commented:
Hi Jose,

That's the problem - i cannot get the profile setup in Outlook at all.

When O2016 goes through the auto config process, it's like it's detecting the wrong type of account.  If you look at both screenshots on my original post, the 2nd one shows it's trying to detect the email account as "internet mail".  I personally have the same setup for myself and its working fine.  Same ISP/DNS provider, same settings (except for different domain names of course).

Thanks,


Jamie
0
JamieD71Author Commented:
Fell foul of an autodiscover bug!!  https://support.microsoft.com/en-us/help/2212902/unexpected-autodiscover-behavior-when-you-have-registry-settings-under

Adding dword of ExcludeHttpsRootDomain  (value 1) solved it.

But Jose, you were on the right track - issues with autodiscover...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JamieD71Author Commented:
Microsoft support provided solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.