Battle .net proxy server dilemma -fix!?

Hi
All of a sudden, my battle.net is saying

Your connection will be run through a proxy server because of your network setup"

This is new.
Things seem to be hinky. I cant join or create games (that are seen by others).
I cant think of anything I've changed
What might be causing this?
Thanks
LVL 1
beavoidAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Maybe you're running a VPN.

Battle.net has a low tolerance level with any type of slightly non-standard connection setup.

Mainly due to people running Bot's to mine for high level gear.

Maybe describe your network setup + someone will have a work around.
0
Jose Gabriel Ortega CastroCEOCommented:
Mm try this:
https://us.battle.net/support/en/article/116108

Check this:
https://us.battle.net/forums/en/starcraft/topic/20759508033

And this:
https://eu.battle.net/support/en/article/23664

One of the 3 has to work. I use battlenet for Diablo3,Wow,SC and SC2
0
☠ MASQ ☠Commented:
When did you notice the error start?  

Assume as you regularly play SC it's something new you've spotted quickly. Do you normally play on Battle.Net or on other servers?

Top reasons why you see:
"Due to your network configuration, your connection to other players must be routed via proxy server" on Battle.Net (your network connection has changed).

    Make sure IE hasn't decided it's Offline
    Open Internet Explorer
    Press Alt + F
    Uncheck "Work Offline"
    If that's already unchecked check your LAN settings as below:

    Press Windows Key + R.
    Type inetcpl.cpl into the Run window.
    OK
    Connections
    Choose "Never dial a connection"
    Choose "LAN settings"
    Uncheck Use a proxy server (if checked)
    Choose "Automatically detect settings" (if Proxy Server above is already unchecked)
    OK

Any recent installation may have changed your networking settings (intentionally or maliciously)

Your ISP may unilaterally change your connection settings (throttling)
You may previously have had port forwarding (:6112) for Blizzard set up on your router and this has been reset (by you, remotely by your ISP or because of a fault).
0
Shaun VermaakTechnical SpecialistCommented:
Apparently common issue after an update. See the blue post in this. Also, try the US server
https://us.battle.net/forums/en/starcraft/topic/20759528341
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
beavoidAuthor Commented:
Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Computer Games

From novice to tech pro — start learning today.