Open Cart configuration

I am unable to configure open cart properly.  refer to this url  - http://104.196.166.154/

I can see proper when i view on server with http://localhost

Please help

Attached Image.
opencart_error_screen.png
rnsrAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Problem looks to be how you've crafted your links.

Take for example this link...

<script type="text/javascript" src="catalog/view/theme/globethm/js/jquery-2.1.1.min.js"></script>

Open in new window


This means catalog is relative to where ever you or your server happen's to have it's current working directory set.

Highly unlikely this will work anywhere, except your local runtime environment.

Change all your links to start with /catalog rather than catalog, to bind all file accesses to your DocumentRoot directory.
0
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
WebPageTest Report provides a visual representation of the problem.

Each red bar refers to a file which can't be located + served, due to how you've crafted your links.

Fix the above + likely your site will start working.
0
Scott Fell, EE MVEDeveloper & EE ModeratorCommented:
Your files are there, http://104.196.166.154/catalog/view/theme/globethm/css/bootstrap.css the issue is your base tag is pointing to localhost. This is why it works locally and not remotely.

<base href="http://localhost/" />

Open in new window


Try removing that or changing to
<base href="http://104.196.166.154/" />

Open in new window


https://www.w3schools.com/tags/tag_base.asp
1
Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Best to just remove base href, as setting this will always cause problems when changing location of your site.

Use DocumentRoot pinned paths + your site will work where ever you install it (whatever directory structure).

After you change/delete the base href, you can run another WPT report (as I did above) to verify your links are fixed.
0
F IgorDeveloperCommented:
In your opencart configuration you need to set the default hostname for your store, If you used http://localhost/ for testing, then you need to change to the right url.

https://forum.opencart.com/viewtopic.php?t=86595

See also your configuration in Admin / Sotres and view your current Store URL
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rnsrAuthor Commented:
Thanks all . Solved the issue with the help.
1
rnsrAuthor Commented:
Thank you all
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.