Unable to ping internal nic from Windows 7 workstation

System: A new Windows 7 workstation serving in a manufacturing area that runs a manufacturing app .  It has 2 NICs.  (1) on the domain with normal IPv4 provisioning, and a 2nd NIC on the 172.16.0.0 range for direct connection to a test machine.

During initializing, the manufacturing app merely attempts to connect to the 2nd NIC via the TcpClient class provided in the .NET (C#) framework, using the IP address 172.16.0.20 and port 69 (the default TFTP port). If a connection is established, the test passes; otherwise it fails, and the MFG app displays that error message.

Previously, on Windows 7 PCs using for instance, an Infineon AN983B PCI Based Fast Ethernet, the the manufacturing app was able to connect to the nic without a cable connection.  But the new Windows 7 system, incorporating a Realtek PCI GBE adapter will not respond to an internal ping with it's cable disconnected.

Is there a method of making a newer NIC respond internally even if the Ethernet cable is disconnected?
Ron NeradNetwork AdministatorAsked:
Who is Participating?
 
8046586Commented:
0
 
Michael LinkInfrastructure EngineerCommented:
The only other way I can see this working is if you use just one NIC and add the other range as an additional IP address within the adapter settings in NCPA.CPL.
0
 
Ron NeradNetwork  AdministatorAuthor Commented:
Thanks Michael, but the workstation needs to stay on the 10.0.0.x LAN while preforming the manufacturing app test in the 172.16.0.0 range.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
8046586Commented:
I don't know which app and instrument you are talking about, but I know that some applications that talks with the instrument over the LAN, and if the app requires connection to the instrument to start, then there are two ways the applications run, online and offline. If this is not the case then you can try cheating the app by creating a loopback network adapter in Windows.
0
 
Ron NeradNetwork  AdministatorAuthor Commented:
Nick;
The manufacturing app makes an initial connection test upon application startup, and this initial check  tests if the 2nd NIC is IP address 172.16.0.20 and port 69 (the default TFTP port) so it can confirm an accessible endpoint.   If a connection is established, the test passes; otherwise it fails, and the MFG app displays that error message.

So I don't think a loopback connector would work, as only one device can have the IP 172.16.0.20.  

I'm looking for a way to force the Realtek, or any newer NIC to respond to pings even when the Ethernet cable is not connected, the way older NICs would.
0
 
8046586Commented:
Let me create the same scenario on my end so will let you know if I can succeed to get ping.
0
 
8046586Commented:
OK, I found it. Use the following command in CMD:

C:\Windows\System32>route ADD 172.16.0.0 MASK 255.255.0.0 172.16.0.20 METRIC 306

The metric 306 will give you the loopback and ping option.

I hope this helps.
0
 
Ron NeradNetwork  AdministatorAuthor Commented:
A physical loop-back is the best workaround in this scenario.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.