ms edge works for tls but firefox,chrome will not

Server: MS Server2016
Installed new Cert.
MS Edge will work with HTTPS.
FireFox, and chrome will not.
Error:
Secure Connection Failed

The connection to the server was reset while the page was loading.

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.
Bob GuthrieAsked:
Who is Participating?
 
Bob GuthrieConnect With a Mentor Author Commented:
Using iis crypto V2
Selected cipher suites and also selected "Best Practices" and then reboot... works ok now
Thanks to all
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
0
 
Bob GuthrieAuthor Commented:
I am not using any logins to some areas of my website.

using Qualys SSL Labs reports the following (among other stuff)
I get a A- because : The server does not support Forward Secrecy with the reference browsers. Grade reduced to A

Firefox 53 / Win 7  R            Server closed connection ( and others)

Edge 13 / Win 10  R            Server negotiated HTTP/2 with blacklisted suite
RSA 2048 (SHA256)   |  TLS 1.2 > h2    |  TLS_RSA_WITH_AES_128_CBC_SHA256
0
 
Bob GuthrieAuthor Commented:
Also with no HTTPS ( using HTTP) it works fine
0
 
Bob GuthrieAuthor Commented:
By Trial and error I found the solution
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.