Remote Desktop into Ubuntu 17.10 from Windows 10

Hi,

I am looking for a solution that I can use to be able to remote control into my Ubuntu 17.10 from Windows 10.

I would like to be able to do this without having to change my "Display Manager". So I want to keep using the same
one that is there. Forgive me as I don't know the correct term.

Is this possible to do this? If so what are the steps.

Thanks,

Ward.
LVL 1
whorsfallAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Good luck with this, would like to know more if it can be done ;)
Peter SchultzSenior Network AdministratorCommented:
whorsfallAuthor Commented:
Hi,

Thanks for the responses. I have done what is suggested and I get an error saying: "The connection was refused by the computer".

I have attached some screen shots to illustrate.

Any suggestions on how to resolve?

Thanks,

Ward
error_win10.png
ping_win10.png
config_linux.png
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Peter SchultzSenior Network AdministratorCommented:
On the Linux side please choose a Security Model:
e.g. Require User to enter the Password:
whorsfallAuthor Commented:
Hi Peter,

Thanks for that. I tried your suggestion and am getting the same error.

Thanks,

Ward.
Peter SchultzSenior Network AdministratorCommented:
lets suggest the firewall is active - and let us allow vnc incoming with:

sudo ufw allow 5900

please test and report ....
whorsfallAuthor Commented:
Hi Peter,

Same result.

I also ran the following.

How can I check the the VNC service is installed or even running?

Have I missed a step?

Here is some extra commands I ran below.

Thanks,

Ward.


nmap localhost

Starting Nmap 7.60 ( https://nmap.org ) at 2017-12-18 22:06 AEDT
Nmap scan report for localhost (127.0.0.1)
Host is up (0.000075s latency).
Not shown: 999 closed ports
PORT    STATE SERVICE
631/tcp open  ipp

sudo service --status-all
 [ + ]  acpid
 [ - ]  alsa-utils
 [ - ]  anacron
 [ + ]  apparmor
 [ + ]  apport
 [ + ]  avahi-daemon
 [ - ]  bluetooth
 [ - ]  console-setup.sh
 [ + ]  cron
 [ + ]  cups
 [ + ]  cups-browsed
 [ + ]  dbus
 [ - ]  dns-clean
 [ + ]  gdm3
 [ + ]  grub-common
 [ - ]  hwclock.sh
 [ + ]  irqbalance
 [ + ]  kerneloops
 [ - ]  keyboard-setup.sh
 [ + ]  kmod
 [ + ]  network-manager
 [ + ]  networking
 [ + ]  open-vm-tools
 [ - ]  plymouth
 [ - ]  plymouth-log
 [ - ]  pppd-dns
 [ + ]  procps
 [ - ]  rsync
 [ + ]  rsyslog
 [ - ]  saned
 [ + ]  speech-dispatcher
 [ - ]  thermald
 [ + ]  udev
 [ + ]  ufw
 [ + ]  unattended-upgrades
 [ - ]  uuidd
Peter SchultzSenior Network AdministratorCommented:
to check if vnc is up and running please try:

netstat -tulpen | grep -i 5900

there should be a line showing the server program is running at this port.

I found an andditional important thing. To avoid problems with Windows one should disable vnc encryption via:

sudo gsettings set org.gnome.Vino require-encryption false

let's go on ...
whorsfallAuthor Commented:
Hi Peter,

Here is the output.


wardh@ubuntu:~$ sudo netstat -tulpen | grep -i 5900
wardh@ubuntu:~$ netstat -tuplen | grep -i 5900
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
wardh@ubuntu:~$ sudo gsettings set org.gnome.Vino require-encryption false

(process:1390): dconf-WARNING **: failed to commit changes to dconf: Error spawning command line “dbus-launch --autolaunch=fc63c12e7cb543e688803e7d144dcc1c --binary-syntax --close-stderr”: Child process exited with code 1
wardh@ubuntu:~$

Plus I have attached a screen shot which I did some config as well with dconf-editor.

Thanks,

Ward.

dconf-editor
Peter SchultzSenior Network AdministratorCommented:
Hi Ward,
dug a little deeper. There is a confirmed Bug in Ubuntu 17.10 concerning Desktop Sharing.
See https://bugs.launchpad.net/ubuntu/+source/x11vnc/+bug/1711948

Sorry for this - until they have finished up this problem i suppose to use teamviewer on both devices https://www.teamviewer.com . Sorry - no better answer at the moment.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.