MRSproxy Hybrid migration

Hi I have a question about MRSproxy. MRSproxy is needed for migrating mailboxes but I do not get it working properly and I do not know how to set this up. can someone explain to me how to set MRSproxy for a hybrid migration?

i`m running exchange 2010 on windows server 2012 R2
Joris DijkAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
hey there,

have a look at the MS docs for this
https://technet.microsoft.com/en-us/library/dn155787(v=exchg.160).aspx

M
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
As outlined in the docs you can use this command to test this is working in advance of moves.

"Test-MigrationServerAvailability -ExchangeRemoteMove -Autodiscover -EmailAddress <EmailAddress> -Credentials (Get-Credential)"
0
Joris DijkAuthor Commented:
Ivè followed the website an used the test command.

when i use the test command ive got an error message that says that the command ins`t reconized.
0
Redefine Your Security with AI & Machine Learning

The implications of AI and machine learning in cyber security are massive and constantly growing, creating both efficiencies and new challenges across the board. Check out our on-demand webinar to learn more about how AI can help your organization!

Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Anytime I get them errors its usually always my syntax is wrong, can you paste in the code your using?
0
Joris DijkAuthor Commented:
Test-MigrationServerAvailability -ExchangeRemoteMove -Autodiscover -EmailAddress administrator@domain.nl -Credentials (Get-Credential)
and ive tryed

Test-MigrationServerAvailability -ExchangeRemoteMove -Autodiscover -EmailAddress <administrator@domain.nl> -Credentials (Get-Credential)
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Can you post exact error msg?
0
Joris DijkAuthor Commented:
error-shell.png
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Have a look at this , looks like you run it on remote side
""
1. That is an Exchange Online cmdlet and doesn't apply to an on-premises server of any version.  You run it in Exchange Online PowerShell.

http://technet.microsoft.com/en-us/library/jj219169(v=exchg.150).aspx

2. The easiest way is a third-party tool like MigrationWiz.  The most cost-effective is to configure hybrid and use New-MoveRequest in Exchange Online PowerShell.  Personally I do not like the method you have to use in EAC to move mailboxes, so I recommend the shell to my customers.
""
0
Joris DijkAuthor Commented:
Ive enterd the command in the exchange manegement shell on my on premises server.
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
I know. Its meant to be used in the office 365 powershell not on premise. on premise is local site, remote site is office 365. Its meant for an exchange online cmdlet.
Guy explaining this here....

https://social.technet.microsoft.com/Forums/azure/en-US/ebf937f7-a247-4dc7-9955-2c7a6c5cf16a/prepping-onprem-exchange-2010-for-cutover-to-office365?forum=exchange2010
0
Joris DijkAuthor Commented:
in the office 365 powershell ive got this result

cmdlet Get-Credential at command pipeline position 1
Supply values for the following parameters:
Credential


RunspaceId         : d454e18e-a3e7-45ad-92dc-3357da411445
Result             : Failed
Message            : AutoDiscover failed with a configuration error: The migration service failed to detect the migrati
                     on endpoint using the Autodiscover service. Consider using the Exchange Remote Connectivity Analyz
                     er (https://testexchangeconnectivity.com) to diagnose the connectivity issues.
ConnectionSettings :
SupportsCutover    : False
ErrorDetail        : internal error:Microsoft.Exchange.Migration.AutoDiscoverFailedConfigurationErrorException: Automat
                     isch opsporen is mislukt met een configuratiefout: Het migratie-eindpunt is niet gedetecteerd met
                     de service Automatisch opsporen. U kunt eventueel Exchange Remote Connectivity Analyzer (https://t
                     estexchangeconnectivity.com) gebruiken om de connectiviteitsproblemen vast te stellen.
                        at Microsoft.Exchange.Migration.DataAccessLayer.MigrationEndpointBase.InitializeFromAutoDiscove
                     r(MigrationEndpoint presentationObject, SmtpAddress emailAddress, Boolean acceptUntrustedCertifica
                     tes)
                        at Microsoft.Exchange.Management.Migration.MigrationService.Endpoint.TestMigrationServerAvailab
                     ility.InternalProcessExchangeRemoteMoveAutoDiscover()
IsValid            : True
Identity           :
ObjectState        : New
0
Todd NelsonSystems EngineerCommented:
Here are a couple of options that may help you.

  1. Re-run the hybrid configuration wizard
  2. Run IISRESET on the Exchange server you ran the hybrid configuration wizard from

You can run the HCW as many times as you need if you find there is a misconfiguration or need to reconfigure hybrid for any reason.

Also, and this tends to be the case about 90% of the time for the hybrid migration projects I work on, running a simple IISRESET on the Exchange server where the HCW was run will finish setting the MRSProxy soon after running the HCW.  A restart of the server may do the trick too.
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
try working through the errors also use the ms docs for that command  back online later or tomorrow. if you want a gig just pm me ill see it.
0
Joris DijkAuthor Commented:
did not found a solution. the problem ocurred in a test enviorment so ive done a rollback of the server to fix it
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Joris DijkAuthor Commented:
because ther was nog solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Office 365

From novice to tech pro — start learning today.