Exchange Autodiscover failing on autodiscover.XML url

I have a server running SBS 2011 and Exchange 2010, Have configured domain DNS SVR Record and our remote web access site works just fine, but for some reason I can't get the Autodiscover to work from outside the network using outlook (any version).  When I run the remote connectivity test for activesync with autodiscover I get the following
      
An error message was returned from the Autodiscover service
XML response:
<?xml version="1.0"?>
<Autodiscover xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
<Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/mobilesync/responseschema/2006">
<Culture>en:us</Culture>
<User>
<DisplayName>UGW Admin</DisplayName>
<EMailAddress>Admin@unitedgear.com</EMailAddress>
</User>
<Action>
<Error>
<Status>1</Status>
<Message>No external URL is available to access this mailbox with Exchange ActiveSync. Your Exchange server configuration needs to be adjusted to allow access.</Message>
<DebugData>UserMailbox</DebugData>
</Error>
</Action>
</Response>
</Autodiscover>
HTTP Response Headers:
Persistent-Auth: true
Content-Length: 736
Cache-Control: private
Content-Type: text/xml; charset=utf-8
Date: Fri, 15 Dec 2017 15:55:31 GMT
Server: Microsoft-IIS/7.5
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Elapsed Time: 1384 ms.

Any assistance would be greatly appreciated.
Brian GraftonNetwork Support SpecialistAsked:
Who is Participating?
 
Cliff GaliherCommented:
Someone attempted to change the external URL for autodiscover and Exchange no longer things it is allowed to serve up the page for the URL requested.

This is all set up by the SBS setup wizard.  The easiest fix is to simply re-run it.  Alternatively, you can use powershell to set the external URL manually in the Exchange Management Shell, and it must match the DNS SRV record you set.
0
 
Lawrence TsePrinciple ConsultantCommented:
For Autodiscover to work externally,  you should make sure:

1. DNS correctly resolve the autodiscover record to a valid IP address you are publishing your front end server (client access server)

2. You have configured autodiscover external URL correctly in Exchange Management Console (I didn't touch Exchange 2010 for very long so I'm not quite sure the admin tool is named like this or not)

To verify external discovery is working, browse to http://<your_exchange_external_fqdn>\autodiscover\autodiscover.xml
Or https://<your_exchange_external_fqdn>\autodiscover\autodiscover.xml
In IE to see what is returned.
0
 
Lawrence TsePrinciple ConsultantCommented:
Another clue is: does this user enabled with Activesync?
0
 
Seth SimmonsSr. Systems AdministratorCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Split:
-- Cliff Galiher (https:#a42405709)
-- Lawrence Tse (https:#a42406222)


If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

seth2740
Experts-Exchange Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.