Trying to change Permalinks link in Wordpress

I'm trying to create a proposal ecommerce site for a small business. I created a permalinks structure that you can see in the image.

Please go to savannahthinktank.com and click on the links - the link structure is working, but the posts are giving me a 404 error.


Second question - I guess I still need to create a 404 page for this site, inside wordpress, and link to it from Apache?

Thanks
permalinks.png
burnedfacelessAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David FavorLinux/LXD/WordPress/Hosting SavantCommented:
From the post editor, assign a category, then try hitting preview page to show the exact link required to view the page.

Also be sure to publish the page, to see the page, when you're logged out (normal visitor).
0
Yatesh ChoudharyCommented:
I tried to go to the category also but they are also not accessible and showing the same error as your posts. I may help you if you could share some more details about your website. Please tell which hosting service you are using and how you installed Wordpress on it.
0
Peter HartCommented:
its probably something to do with the file privileges
setting the permalinks will create a new .htaccess file.

does it work when you choose a another option and see if it works
0
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

burnedfacelessAuthor Commented:
I'm using Linode. How I installed Wordpress

I've created new posts after the change, and it still does not work.
0
Peter HartCommented:
then maybe  its  to do with the file privileges
setting/changing the permalinks will create a new .htaccess file.
and maybe the .htaccess file is not being created/updated
check the privileges of the folders on your root

I notice the search function (I searched for "test")   returns the post but again clicking on the results causes a page not found.
I'll guess when you add a menu, the menu items will not work also.

can you use FTP to access the .htaccess file in the root of the website and post what is in there?   Saving the permalinks updates the .htaccess file

also looking at the way you install the system it may be that  the Apache "mod_rewrite"  extension is not working
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kathrin JohnCommented:
I have install WordPress on Linux operating system and face the same issue but all I have done is to set the permalinks to default then set it back to post-name which fix this issue. I would recommend you to see your permalinks setting and .htaccess file.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
E-Commerce

From novice to tech pro — start learning today.