Trying to change Permalinks link in Wordpress

I'm trying to create a proposal ecommerce site for a small business. I created a permalinks structure that you can see in the image.

Please go to savannahthinktank.com and click on the links - the link structure is working, but the posts are giving me a 404 error.


Second question - I guess I still need to create a 404 page for this site, inside wordpress, and link to it from Apache?

Thanks
permalinks.png
burnedfacelessAsked:
Who is Participating?
 
Peter HartCommented:
then maybe  its  to do with the file privileges
setting/changing the permalinks will create a new .htaccess file.
and maybe the .htaccess file is not being created/updated
check the privileges of the folders on your root

I notice the search function (I searched for "test")   returns the post but again clicking on the results causes a page not found.
I'll guess when you add a menu, the menu items will not work also.

can you use FTP to access the .htaccess file in the root of the website and post what is in there?   Saving the permalinks updates the .htaccess file

also looking at the way you install the system it may be that  the Apache "mod_rewrite"  extension is not working
0
 
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
From the post editor, assign a category, then try hitting preview page to show the exact link required to view the page.

Also be sure to publish the page, to see the page, when you're logged out (normal visitor).
0
 
Yatesh ChoudharyCommented:
I tried to go to the category also but they are also not accessible and showing the same error as your posts. I may help you if you could share some more details about your website. Please tell which hosting service you are using and how you installed Wordpress on it.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Peter HartCommented:
its probably something to do with the file privileges
setting the permalinks will create a new .htaccess file.

does it work when you choose a another option and see if it works
0
 
burnedfacelessAuthor Commented:
I'm using Linode. How I installed Wordpress

I've created new posts after the change, and it still does not work.
0
 
Kathrin JohnCommented:
I have install WordPress on Linux operating system and face the same issue but all I have done is to set the permalinks to default then set it back to post-name which fix this issue. I would recommend you to see your permalinks setting and .htaccess file.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.