Can't get RDP Session to Span Across Two Monitors - Windows 8.1

Hello Experts,
I cannot get my RDP session to span across two monitors. I have tried various adjustments in the parameters of the RDP connection, such as: use multimon, span monitors, manually assigning a desktop width and height, screen mode, etc.  There is an issue with my how Windows identifies my monitors: I have only two monitors, but it shows that I have three. The monitor being identified as monitor 1, is not a monitor that is actually displaying anything and its resolution shows 640 x 480, while monitors 2 and 3 are displaying at resolution 1920 x 1080. I tried disabling the monitor that is the 'ghost' monitor in the device manager and unplugging/restarting the computer, but there was no change. What I most need is for my RDP session to span my two monitors, I don't care about the ghost monitor unless you think it is causing the problem with the RDP session span...
I much appreciate any help you can give me with this.
Respectfully, Chop
ChoppAsked:
Who is Participating?
 
arnoldCommented:
Try

mstsc /w:3840 /h:1080 /v:hostname
When connecting, the RDP dimention will span two monitors with 1920x1080 resolution.

You can not use the full screen mode, since it will be locked on one screen.
You gave to size the window to span two monitors.
The above presumes you have length wise monitors, if you have your monitors tiled top/bottom, change the option to reflect /w:1920 /h:2160
0
 
8046586Commented:
Save the RDP connection on the desktop. Open it with notepad and you should see the following:
screen mode id:i:2
use multimon:i:0
desktopwidth:i:1920
desktopheight:i:1080
session bpp:i:32
........

Modify the first two lines and save:
screen mode id:i:1
use multimon:i:1

I hope this will help.
0
 
ChoppAuthor Commented:
I have tried all of those steps already.

I believe the problem may be related to the fact that Windows is seeing an extra monitor. Do you know how to access the bios on my HP Envy, system model 700-214, in order to disable the onboard video card? I've already tried using pressing F2, F6, F10 and the escape key on start-up.
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
8046586Commented:
Do you remote to Envy or from Envy? Is the remote desktop actually a laptop and connected to the port replicator/docking station?
To get to BIOS on HP, you should use F10. Try F9, then Esc and you might get a list of choice including BIOS (F10).
0
 
ChoppAuthor Commented:
I am remoting from Envy.  When I use a different computer (not the Envy) the RDP connection does display on both monitors. (The remote computer is not the problem.)
I've already tried using the keys you listed for displaying bios.
0
 
8046586Commented:
As I can understand you have attached another screen to your laptop and currently you can see a replicated screen on both monitors, but you would like to have extended monitors and on one motirot to look at your Envy desktop and on the other monitor the RDP desktop?
If that is right then, you should play with your Windows display settings and select extended screen for the second monitor.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.