Printer disconnect automatically after installing sonicwall

Hello Experts,
I just installed sonicwall tz400w and everthing is going well except printer. Printer disconnect automatically after few minutes. I have to connect them manually again and again. I am using commercial printer by konica minolta and i use fiery app on Konica. Its working fine without the firewall.  Please help
nakul dewanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Blue Street TechLast KnightCommented:
Hi Nakul,

How is it "disconnecting"? What is it disconnecting from...the print server, the PCs, etc.? Can you go over your setup a little more...are you using a print server or are the PCs just connecting strait to the Printer? Is the printer in the same Zone as the other machines?

How are you testing the printer without the SonicWALL - direct test using an Ethernet cable straight to the printer?

Let me know so I can help. Thanks!
nakul dewanAuthor Commented:
Hi ,

So Setup is simple. We have 5 computers and one 16 port switch 2 commercial printer and a verizon wireless router.

Printers are connected through switch. we use fiery desktop app to connect with those printer. Printers are added on this app and usually we just click on connect and it connects.

Now after installing firewall, i am trying to do it same way. I click on connect and it connects. I am able to print but after 3-4 minutes it will disconnect me from the printer. Then i have to reconnect it to make it work.

All computers and printer are connected to switch. Internet is working fine. Just having issue with the printer.
nakul dewanAuthor Commented:
To test without sonicwall, i just unplugged the ethernet cable from lan port of sonicwall and plugged in back to verizon router.
SolarWinds® Network Configuration Manager (NCM)

SolarWinds® Network Configuration Manager brings structure and peace of mind to configuration management. Bulk config deployment, automatic backups, change detection, vulnerability assessments, and config change templates reduce the time needed for repetitive tasks.

Blue Street TechLast KnightCommented:
And no other changes occurred except replacing your firewall? What was the previous make/model you replaced?

Did you change your IP schemas or VLANs? Are you running VLANs or separate Zones for the printers and the computers?
nakul dewanAuthor Commented:
There was no firewall previously.

No, i didn't touch any of the stuff. I just simply installed it and enable wireless network. Thats it
Blue Street TechLast KnightCommented:
OK so they had a modem before with a switch or no switch? Verify the correct network setting are in place in the printers.

I'm wondering how the DHCP configuration was setup previously...maybe there are IP conflicts. Are the printer statically assigned now and is SonicWALL managing the DHCP?

If you they are assigned and SonicWALL is managing DHCP, remove the static assignment and create Static Assignments within the SonicWALL (Network > DHCP Server).

Can you continuously ping the printers from a computer (RUN > CMD, type ping <print_ip> -t) and the SonicWALL (System > Diagnostics > Diagnostic Tools, select Ping)?
nakul dewanAuthor Commented:
Yes. There is a verizon modem/router with 16 port switch. I am not sure about the old settings.
nakul dewanAuthor Commented:
Yes sonicwall is managing DHCP
You may have an IP address conflict.

Does the printer have a fixed IP address? If yes, did you set it manually, or is it set as a reservation on the Sonicwall. What is the IP address of the printer?

I just simply installed it and enable wireless network. Thats it
You must have changed something else. If the Sonicwall manages DHCP, what DHCP server did you use before the Sonicwall? And how come the Sonicwall is now doing it?
nakul dewanAuthor Commented:
Yes i have manually added ip address on printer.

No i have not added any ip address on sonicwall for printer.
If the sonicwall gives that address to any other device you are in trouble. You need to check your settings on the sonicwall (and the previous DHCP server) to make sure there is no conflict.
BTW you didn't answer my other question: what else did you change to make the sonicwall the DHCP server?
Blue Street TechLast KnightCommented:
Please re-read my previous post and let me know if you can ping as suggested: https:#a42406872

I'm almost positive this is an IP Address issue. Are you saying your old subnet was The is the SonicWALL default so unless your modem/router had the same subnet (which is highly unlikely) then I think this is the major change that has taken place "under the radar" so to speak. Did you put the Verizon modem into transparent mode and disable all firewall, NAT and DHCP functions?

What I said was get the MAC address of the printers and add them in the SonicWALL DHCP server as Static Addresses (that is the Windows equivalent of DHCP Reservations). This requires you to remove all the static entries you made in the printers previously, e.g. Gateway IP, IP Address, DHCP Server (if applicable), and DNS settings. Save and reboot the printers.

Then retest and let me know.
nakul dewanAuthor Commented:
When i ping printer ip address, Most of the time it fails. Request timed out or there will be packet loss.
Blue Street TechLast KnightCommented:
Are you pinging the printer name, FQDN or the IP address? Did you notice you have a reply from! What does that address belong to?

Is the base station of the printer or the fiery of one of the printers?
nakul dewanAuthor Commented:
Thats my computer Ip.

I have 2 printers and both have Fiery on it.

Going back to my earlier question.

Which DHCP server did you use before the Sonicwall?
Is that device still on the network? If yes, did you disable it as a DHCP server?
nakul dewanAuthor Commented:
Yes Verizon router is still on network. No i didn't made any changes on that device.
Blue Street TechLast KnightCommented:
Your SonicWALL should have DHCP Server conflict detection enabled - please verify. You should put your Verizon modem into Bridge Mode aka Transparent Mode. If not you could have double NATTING going on. You need to make sure you have disabled all the firewall, NAT and DHCP functions in the Verizon Modem.
As Blue Street Tech says, make sure there is only one DHCP server on your network.
nakul dewanAuthor Commented:
Yes DHCP conflict detection is enabled
nakul dewanAuthor Commented:
No i didn't made these changes on verizon.
Blue Street TechLast KnightCommented:
Go into your SonicWALL under Network > Interfaces and tell me if the WAN IP address is local or public.
nakul dewanAuthor Commented:
Its local.
Blue Street TechLast KnightCommented:
OK so you have double NAT going on and I'm pretty positive you have everything else I previously described including another DHCP server. I don't want to could the issue so let me be clear - I belive you have another DHCP Server from the Verizon Router, which is the route cause for your issue. You also have double NAT going on which is not the root cause but may cause you additional issues down the road. So while you are taking care of the rogue DHCP server why not continue your remediation of all things that will cause you issues in the future in one move. With double NAT, you will experience issues with anything using uPNP, any device requiring to open ports without user intervention, opening a specific service port/s, connecting to a VPN tunnel, remote access, or visiting secure sites with SSL, etc.

Here is what to do:
1. Put the Verizon Router into Bridge Mode aka Transparent Mode - if you don't know how to do this post the make/model and I can walk you through it or call your provider's support and have them walk you through it. This will get rid of NAT on the Verizon Router so that you only have NAT occurring on the SonicWALL.
2. Disable DHCP Server and any other firewall/security features.
3. Reconfigure the WAN Interface in the SonicWALL - this time it should have the Public IP address.
4. Remove all statically assigned IP addresses in the network - its a Bad Practice. Best Practices are to, in your case, create the Static IP addresses (the equivalent of MSFT DHCP Reservations) within the SonicWALL DHCP server.

I have already gone over everything else that needs to occur in my previous posts - please re-read them.

Let me know once you have done this.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Blue Street TechLast KnightCommented:
Any update on is the re-configuration going? Did you find the other DHCP Server?
nakul dewanAuthor Commented:
Hi BlueStreetTech,

Sorry for the late response. 2 cables were causing packet loss. I changed all network cables and got a new switch. Its working fine now. Thank a lot for your support. You are always helpful.
nakul dewanAuthor Commented:
Thanks BlueStreetTech.
Blue Street TechLast KnightCommented:
You're very welcome! Its my pleasure.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.