Domain Trust Issue

We have an older PC that wasn't configured with our new DNS servers so I logged in and made the change. I logged out and attempted to sign back in but get the message, "the trust relationship between this workstation and the primary domain failed," and "The security database on the server does not have a computer account for this workstation trust relationship." I attempted to login as the local admin but get the same errors. I also unplugged it from the network, rebooted and attempted to login but get the message that there are no logon servers available.

 I've had to do this in the past and have always been able to login as the local admin, remove it from the domain and then re-add it and it's worked fine. This is a Windows 7 x64 machine.
itgolferAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Danny VerrazanoCommented:
Sounds like its still trying to login to the domain with cached credentials instead of locally.  

  • Verify the computer has the correct time.
  • In the logon screen put .\administrator to logon with local admin and password.  

The second issue you may have is the secure channel is broken between that computer and the domain.  

  • Search the domain for the computer name.  If the computer is in the domain just delete it or reset it (right click > reset)
  • On the computer be sure the DNS servers are configured properly.
  • Make sure all IP info is correct (is it static IP or DHCP, etc...)
  • If the computer is joined to the domain, go through dis-joining the domain by adding it to a workgroup (WORKGROUP) and restart.
  • Logon again and join the computer back to the domain (use the full dns name of the domain and NOT the short NETBIOS name.  Make sure to use something like your.domain.com)

It will join and you will be happy
OR
It will still not join and then we have to start doing more investigation such as pinging the DNS servers or using nslookup to troubleshoot.

Let us know!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
itgolferAuthor Commented:
Perfect, thank you! The second step seems to have resolved the issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.