A network-related or instance-specific error...

I'm following a tutorial in Pro ASP.NET MVC 5 page 170.  Under "Creating the Database", it says to go to Server Explorer > Choose Data Source, Select Microsoft SQL Server, Continue, enter server name (localdb)v11.0, Use Windows Authentication, Select or enter a database name: SportsStore.

When I test the connection I see the error: A network-related or instance-specific error...

I tried replacing (localdb)v11.0 with LocalDB but got the same error.

What else should I try?
Barry SweezeySoftware EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zephyr_hex (Megan)DeveloperCommented:
Do you have MS SQL Server installed ?  If so, is it the express version ?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ryan ChongCommented:
make sure you have provided correct Server name when you connecting to the database.

and make sure the MS SQL service is running fine?
1
Vitor MontalvãoMSSQL Senior EngineerCommented:
Are you trying to connect to a SQL Server named instance or the default instance?
It will help if you can post a print screen of the configurations that you're using.
0
Barry SweezeySoftware EngineerAuthor Commented:
Went into the installer and selected Workloads > .net Desktop Development > SQL Server Express 2016 LocalDB.   I don't remember having to explicitly select that before.  Then in the Server Explorer I entered Server Name (localdb)\MSSQLLocalDB , which I read somewhere else. That worked.  LocalDB and LocalDB)\V11.0 didn't work.  Thanks for your help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.