Make Outlook default program in Windows 10

We are rolling out Windows 10 computers.  I've noticed the at when i click on on a link that is MailTo and is suppose to open outlook new email a windows opens up to log into the Microsoft email and doesn't open Outlook New Email.  The computer has Office 2010.  

If i go into Settings > Defualt apps > Email I select MS Outlook and it works but I am doing this manually while signed on as the user.  How can I do this group policy so it affects all Windows 10 computers?  I already have policy to set default file associates to open with certain programs such as IE11 (instead of Edge) and .pdf with Adobe Reader.  

Thanks for your help.
ozzalotAsked:
Who is Participating?
 
DonNetwork AdministratorCommented:
1
 
Tom CieslikIT EngineerCommented:
Here you can find Microsoft tutorial how to set Outlook as default mail program in GPO

https://support.microsoft.com/en-us/help/2008044/how-to-configure-the-default-e-mail-client-using-group-policy
0
 
ozzalotAuthor Commented:
I saw that and have tried it but it doesn't seem to do anything.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
ozzalotAuthor Commented:
I have added .adm to group policy but I still not change.  See the attached picture.

I have also added the following to the file associations file i have created but it does not make a difference:
<Association Identifier="mailto" ProgId="AppXydk58wgm44se4b399557yyyj1w7mbmvd" ApplicationName="Microsoft Outlook" />
2017-12-19_143547-Defualt-Email.jpg
0
 
Tom CieslikIT EngineerCommented:
To make policy work for Windows 10 computer you must do 2 thinks

1. Setup appropriate rights in  delegation tab

Capture.JPG
root/CIMv2

select * from Win32_OperatingSystem where (Version like "6.%" OR Version like "10.%") and ProductType = "1"

Open in new window

2. Use WMI filter and define Windows 10

Capture.JPG
1
 
ozzalotAuthor Commented:
Permissions are set already.  All of my Windows 10 group policy settings I can see applied on my workstations.  It is only this policy i do not see applied.
0
 
Tom CieslikIT EngineerCommented:
Did you try set this policy to ENFORCED ?
0
 
Tom CieslikIT EngineerCommented:
CHECK in CMD windows gpresult /R
It will show you if policy was applied to workstation
0
 
ozzalotAuthor Commented:
Sorry forgot I had this question open. Thank you for your help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.