Need to run 32 bits program on a Windows 7 64 bits

Hi,

I need to run a 32 bits program on Windows 7 64 bits.

So I installed it in C:\Program Files (x86)\erp\runerp.exe

That program must read an ini file located at C:\Windows\runerp.ini

Currently, I can run the program but it is unable to read the ini file so it's not working.

I also tried to run it "As Administrator"

Domain users have full rights on the ini file.

Can you please help me to make it work?

Thanks and cheers,
Rene
LVL 10
ReneGeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joe Winograd, Fellow&MVEDeveloperCommented:
Hi Rene,

> That program must read an ini file located at C:\Windows\runerp.exe

That's not a folder. Even if you mean C:\Windows\, that's not a folder where an ini file should be stored. An ini file is typically stored in %AppData% if you want one for each user or in %ProgramData% if you want the same ini file for all users. Btw, I don't think the issue has anything to do with running a 32-bit program on 64-bit Windows — that should work fine. Regards, Joe
0
JohnBusiness Consultant (Owner)Commented:
Where is the INI file. It may not work if located in Program Files because of Windows security.  You may need to store in a non-Windows secured location (Users folder as Joe suggested might work better.  Or make a folder c:\special_programs where Everyone has permission and keep the INI file there.
0
ReneGeAuthor Commented:
Hey John :)

Oops, thanks for noticing that.

I fixed my question :)
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

ReneGeAuthor Commented:
The problem, is that I`m not the programmer and she had the brillian idea to put it in C:\Windows
0
JohnBusiness Consultant (Owner)Commented:
I have seen programmers put data and like files in secured locations and then the programs do not work. Pick a neutral location (from the point of view of security)
0
ReneGeAuthor Commented:
Hey Joe,

Thank for noticing that as well :)
0
ReneGeAuthor Commented:
John, the location of the ini file is hard coded
0
David Johnson, CD, MVPOwnerCommented:
Yes the programmer was absolutely brilliant

you can create a shim for this program that will redirect calls from this program to c:\windows to somewhere else using the application compatibility toolkit
0
ReneGeAuthor Commented:
@Joe

Any ideas how I can make that work?
0
JohnBusiness Consultant (Owner)Commented:
You need to get the programmer to change the program. location of the ini file is hard coded  That is an XP style of programming
0
ReneGeAuthor Commented:
@David

Please note: Microsoft ACT version 5.6 is no longer actively supported. Please download the latest version from the Windows Assessment and Deployment Kit (ADK) for Windows 10 in the Related Resources section of this page

My client has Windows 7.  Will it work?


@John  That's my last recourse


Thanks :)
0
Joe Winograd, Fellow&MVEDeveloperCommented:
Hi Rene,
I don't know how to make that work, but I see David's post about creating a shim for it. I never heard of that technique, but I have 100% confidence in David, so definitely give that a try. Or, if possible, contact the programmer and have her place the ini file where it belongs — in either %AppData% or %ProgramData%. Regards, Joe
0
David Johnson, CD, MVPOwnerCommented:
ACT 5.6 was released in the Windows 7 timeframe.  Creating a shim is most useful when the application gets installed on many computers..
0
ReneGeAuthor Commented:
Hi David,

Sounds very cool!

I will try tomorrow.

A super thanks to all :)

Cheers
0
huacatCommented:
Hi ReneGe, Just set the file C:\Windows\runerp.ini permission as:
remove all current permissions,
grant everyone with full rights.
0
Shaun VermaakTechnical Specialist/DeveloperCommented:
Can you change the location of the INI file?
0
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
Since Vista, applications not being compiled with the virtualization aware flag should automatically get a shim, redirecting writes to protected folders into %AppData%\Local\VirtualStore. If the file is not created automatically there, move the file to that location, and it should work.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ReneGeAuthor Commented:
I need help with "Microsoft Application Compatibility Toolkit 5.6"

Should I create a new question, or we continue here?

Thanks for all your help
0
McKnifeCommented:
You read Qlemo's comment? It should work automatically, no shim needed.
So skip that shim thing. Please verify: is UAC even on? It is needed here.
0
ReneGeAuthor Commented:
Hi Qlemo,
Thanks for your solution.  I tried your solution but it did not work.

By the way, ""%AppData%\Local\VirtualStore\" does not exist.
 %AppData% points to -> C:\Users\UserName\AppData\Roaming\
"C:\Users\UserName\AppData\Local\" exist
"C:\Users\UserName\AppData\Local\VirtualStore\"
Should I create "C:\Users\UserName\AppData\Local\VirtualStore\" and put the ini file there?

Hi McKnife,
UAC was off.  I will try Qlemo's solution again with UAC on this time
0
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
I knew I forgot to mention something to be required (UAC) - thanks, McKnife.
And of course c:\Users\%UserName%\AppData\Local\VirtualStore is the correct "root" folder, which corresponds to C:\. That is, you have to create a Windows folder, then put the ini into that folder.
0
ReneGeAuthor Commented:
Tried in "C:\Users\username\AppData\Local\VirtualStore\inifile.ini" and it did not work :(
0
McKnifeCommented:
Again: C:\Users\username\AppData\Local\VirtualStore\Windows is the path where the ini belongs.
0
ReneGeAuthor Commented:
In "C:\Users\%username%\AppData\Local\VirtualStore\Windows\" works -> Wohoooo!

But now getting another problem.  WIll come back to you shortly
0
JohnBusiness Consultant (Owner)Commented:
If username is the user of the computer and that location does not work, there may be some issue with the program.

P.S. You said the location works and it should work for this type of application
0
McKnifeCommented:
Unfair point distribution. Qlemo's was the initial idea.
0
McKnifeCommented:
Fairer point division.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.