Exchange 2013 cummulative update in Hybrid environment

Hello Experts,

We are having Hybrid Environment with below list, now we need to update all exchange 2013 Server to latest Cummulative update 17, currently on all Server are running with Cu13

2 = Mailbox Server
2 = Hybrid Server
2 = Edge Server

Please suggest, if any article for hybrid environment Cumulative update process and what things we need to keep in mind ?

Also, is  Hybrid configuration wizard need to be run after all Exchange server updated to latest CU ?

Thanks,
Addy
LVL 5
Addy NadiaExpertAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
1. Backup - ensure you have any suitable available backups.
2. Patch them in an order that keeps the systems online.
3. If you are really concerned open a one off MS case in advance of the patching.
4. Sorry I have no documentation for this as I do not know your specific config although I have a rough idea at overview.
0
Todd NelsonSystems EngineerCommented:
Please suggest, if any article for hybrid environment Cumulative update process and what things we need to keep in mind ?

Take a look at this article for the order to update the servers ... Installing Cumulative Updates and Service Packs for Exchange Server 2013

CU19 for Exchange 2013 was released on Tue 19 Dec.  As a result, only CU18 and CU19 are supported.  Therefore, no need to upgrade from CU13 (unsupported) to CU17 (unsupported).

Additionally, you may need to upgrade in phases to maintain compatability with .NET Framework without breaking Exchange.  Refer to the Exchange Server Supportability Matrix.


Also, is  Hybrid configuration wizard need to be run after all Exchange server updated to latest CU ?

No.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Addy NadiaExpertAuthor Commented:
i did not get the below  ???

CU19 for Exchange 2013 was released on Tue 19 Dec.  As a result, only CU18 and CU19 are supported.  Therefore, no need to upgrade from CU13 (unsupported) to CU17 (unsupported).  

and also for below , are you sure ?? is there any article that mentioned this

Also, is  Hybrid configuration wizard need to be run after all Exchange server updated to latest CU ?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Addy NadiaExpertAuthor Commented:
and also we are having  .net framework 4.5 on all servers ?? so we need to upgrade .net framework to 4.6.2  ? and what is the procedure..
0
Todd NelsonSystems EngineerCommented:
You stated in your original request, that you are planning to upgrade to the latest CU --which you stated as CU17.  CU17 is no longer supported by Microsoft.

You can make an attempt to upgrade directly to CU19 however, you may be prompted to install .NET Framework 4.6.2 at a minimum.  But keep in mind, .NET Framework 4.7.1 is now supported with CU19 and will be a requirement come June 2018.  I would recommend installing 4.7.1 after CU19 is installed so you do not have to do it later.

Not exact on the current update process, but this is what it looked like when CU16 was released...
With CU16 for Exchange 2013 and newer, .NET Framework 4.6.2 is a requirement.  If you are upgrading from a CU version prior to CU16, you must upgrade Exchange 2013 to CU15 first, then upgrade to .NET Framework 4.6.2, and finally upgrade Exchange 2013 to one of the newer, supported CUs.
0
Addy NadiaExpertAuthor Commented:
as per customer need, we need to update to Cu17 not the latest one,.

so can we install directly from cu13 to Cu17 ? and before cu17 install, do we need to update .net framework 4.6.2 ?
0
Todd NelsonSystems EngineerCommented:
so can we install directly from cu13 to Cu17 ?

As stated in a prior response, most likely not.  However, you can try it.  The install will stop if it is a requirement.


before cu17 install, do we need to update .net framework 4.6.2 ?

As stated in a prior response, "With CU16 for Exchange 2013 and newer, .NET Framework 4.6.2 is a requirement."  That means .NET Framework 4.6.2 is a requirement. for CU16, CU17, CU18 and CU19.

Review the link to the Exchange Supportability Matrix provided in a prior response.
0
Addy NadiaExpertAuthor Commented:
so according to you,
first i can install .net framework 4.6.2  on all exchange server
second i need to install Cu17 on all Exchange Server as per below

2 Mailbox Server
2 Hybrid Server
2 Edge Server
0
Addy NadiaExpertAuthor Commented:
Please suggest as per last query

any special care for Exchange Server for upgrading to cu17
0
Todd NelsonSystems EngineerCommented:
.NET Framework 4.6.2 is not supported with Exchange 2013 CU15 or older.  So, if you install 4.6.2 before CU16 or newer, you may break Exchange.

Upgrade the non-Edge servers before the Edge servers.
0
Addy NadiaExpertAuthor Commented:
we are going to upgrade from cu13 to cu17

so before cu17 we need to install .netframework 4.6.2 ? right
0
Todd NelsonSystems EngineerCommented:
No.  You didn't understand what I said or review the Exchange supportability matrix previously provided.

To summarize, install a supported CU, then install .NET 4.6.2.

Again, the CU install will tell you if a prerequisite is missing and stop the CU install before it begins.
0
Addy NadiaExpertAuthor Commented:
supported CU means ??

so you mean i cannot go directly from cu13 to cu17
0
Todd NelsonSystems EngineerCommented:
It means that currently only CU18 and CU19 are supported by Microsoft for Exchange 2013.  If you run into any issues and need to contact MS, they will tell you to install a supported CU (i.e. Exchange 2013 CU18 or Exchange 2013 CU19).
0
Addy NadiaExpertAuthor Commented:
so mean, i can install directly Cu18 from current Version cu13, and before that i need to install .net framework 4.6.2 ?
0
Addy NadiaExpertAuthor Commented:
Hello,

i checked currently i have 4.6.0  .net framework is installed on server, So now is it safe to install .net 4.6.2 before cu17 ?
0
Addy NadiaExpertAuthor Commented:
Hello Todd,

Cu 15 is not avialable to download on microsoft site

Please suggest, how i can go for upgrade from cu13 to later version

Thanks,
Addy
0
Seth SimmonsSr. Systems AdministratorCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Split:
-- Todd Nelson (https:#a42411779)
-- Todd Nelson (https:#a42412919)
-- Todd Nelson (https:#a42422653)


If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

seth2740
Experts-Exchange Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.