Outlook 2016

I want to migrate from exchange 2010 to office365 and have now updated my autodiscover DNS entry.

After removing mail accounts and adding them back in,  phones and other devices switch fine after the DNS change,

however; Outlook 2016 on prem still always points itself to our exchange servers. I've tried removing all profile data in case it had the autodiscover cached somewhere but now i'm wondering if it is an exchange 2010 / domain type setting.
My domain controllers are Server 2008 + 2012 in case that matters.
Can anyone help me out?

Thanks very much.
jamiegfAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Todd NelsonSystems EngineerCommented:
What method of migration did you perform ... cutover, staged or hybrid?
0
Loretta HarrisCommented:
Is it possible there is still in entry to your old Exchange 2010 server in your internal DNS server?
Also I believe we had to create a CNAME record for autodiscover and a CNAME for the msoid host for Office 365.

Hope this helps.
0
jamiegfAuthor Commented:
Hi Todd. I am using a Hybrid method as I need to keep a few domains on here (whilst i figure out how to get this right).
So far I've just used the migration wizard in the "Admin" part of office365.  Its has worked okay for devices not on our domain in our office.


Hi Loretta. If i ping (from inside our network) autodiscover.mydomain.com it pings the right place as opposed to our exchange boxes. So the DNS entries are looking to be right. Also, our mobile devices work okay on the same network wirelessly. I am only being requested to set up 3 entries (MX, TXT and CNAME for autodiscover) in the domains section.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Todd NelsonSystems EngineerCommented:
Typically, you should not make changes to the autodiscover (CNAME or A) or MX records until after all of the mailboxes for a specific domain have been migrated to EXO.  The same holds true for the autodiscoverinternalserviceuri setting in Exchange.

I guess I'm curious about the Outlook profile still pointing to on premises statement you made.  After migrating an on premises mailbox to EXO, the Outlook reconfiguration should be seamless.  Does the Outlook profile have on premises mailboxes it is still connecting to?  If it does, then the profile will still point on premises for those specific mailboxes.
0
Loretta HarrisCommented:
Agree with Todd's comments.  I also wonder if all the old profile data has been removed.  Have you tried manually entering the settings in the profile rather than letting autodiscover handle it (not ideal, but may be worth a try)?
0
jamiegfAuthor Commented:
Have now resolved this.
The solution is from here:
https://www.itjon.com/outlook-still-trying-to-connect-to-old-exchange-server-after-moving-to-office-365/

And for those who hate a link (or if it goes dead)

The reason:
Outlook uses SCP (Service Connection Point) to autodiscover your local exchange server before it tries DNS


The solution:
Add: ExcludeScpLookup=dword:1
to
HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoDiscover
(This is for Outlook 2010, Outlook 2013 and Outlook 2007 will be the different area such as xxx\15.0\xxxx)


You can also delete the SCP record altogether using ASDI edit:

Select the “Configuration” naming context
Drill down to:
CN=Services\
CN=Microsoft Exchange\
CN=<Your Org name>\
CN=Administrative Groups\
CN=Exchange Administrative Groups\
CN=Servers\
CN=<Your Server Name>\
CN=Protcols\
CN=Autodiscover\
And delete the CN=<Your Server Name> of class serviceConnectionPoint in there
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jamiegfAuthor Commented:
This fixed my issue
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.