• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 82
  • Last Modified:

NO DNS

I have  domain controller that handles dhcp and dns.
I have a wired workstations and a wireless access point that handles the building.
New Laptops I am deploying will work on the wirless, but fail dns when connected to the wire.  With or with out the wireless connected.   As long I am on the wireless all is ok,  hook up the wire, it obtains a new ip says it is connected to internet, but no dns.
I have tried static, no luck...
Only half of the new LT's   (MSI) are affected.....
0
Tim Dawson
Asked:
Tim Dawson
  • 10
  • 7
  • 4
  • +1
11 Solutions
 
8046586Commented:
When you are staying connected to the internet, are you able to browse the web?
0
 
Tim DawsonIT ManagerAuthor Commented:
No.  It says connected,  but will not browse.
0
 
8046586Commented:
Can you see the LAN address registered into the DHCP? Did you try ipconfig /release and /renew?
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
masnrockCommented:
Are the DNS settings received by the laptops the same, whether on wired or wireless? There's nothing loaded on them to disable the NIC cards somehow, correct?

I would be checking 2 things:
1) Try using tracert from any of the machines on a wired to 4.2.2.2 and see if that packet goes all the way successfully. If not, then where does it stop going?
2) Check that there isn't some incorrectly connected wire somewhere in the building.
0
 
8046586Commented:
Check also the BIOS; HP models have one tick in advanced settings which is disabling the wifi once you will plag the cable. Maybe you can find that feature in your BIOS. If you are running the latest Intel chipset that might be the BIOS issue. We have a problem with most recent HP laptops somehow related to the LAN and fix for us fas playing with the BIOS versions.
0
 
Tim DawsonIT ManagerAuthor Commented:
Yes on both.  Same result.
0
 
8046586Commented:
Try restarting the Switch; you might have some conflict there.
0
 
Tim DawsonIT ManagerAuthor Commented:
Both connections show different ip's   and the same  DNS.   Only way to internet is to unplug the cord.
0
 
Tim DawsonIT ManagerAuthor Commented:
I'll check in the BIOS.  Kind of reverse the way I think.   But when plugged in it shows both connections are of ok  ipconfig
0
 
masnrockCommented:
Did you restart the switch(es)? And what do the connections at each desk look like? Do you connect directly to the wall, or to through a phone? If through a phone, try bypassing it.

Both connections show different ip's   and the same  DNS.
Are the IP addresses starting with the same numbers? For example, 192.168.10 ...
0
 
8046586Commented:
If you are getting through the WiFi outside, but not through the LAN having the same DNS showing in both connections try disabling the WiFi and manually setup the LAN with the IP that you were getting through the WiFi. If you will get successfully on internet then you should troubleshoot the router firewall
0
 
masnrockCommented:
Another thought: when you're connected by wire, go to the command line and run this:
nslookup www.google.com

Open in new window


Post the result.
0
 
Tim DawsonIT ManagerAuthor Commented:
nslookup www.google.com     gives me   172.217.7.4
0
 
8046586Commented:
Your DNS works fine if you can resolve the name. Scheck your switch.
0
 
Tim DawsonIT ManagerAuthor Commented:
Hummm  weird.   Ok  Can't restart now.  too many connected....    By the way did I mention I  CAN connect to my intranet just fine,  just wont go out bourse.

I'll take the thing home and try mine at home...
0
 
Tim DawsonIT ManagerAuthor Commented:
I'll also look in the BIOS like you suggested.   If I can get to it.   Never touched an MSI before.  :)
0
 
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Maybe I'm missing something...

You said...

As long I am on the wireless all is ok,  hook up the wire, it obtains a new ip says it is connected to internet, but no dns.

Simple approach...

1) If WiFi is working, just use WiFi.

2) If copper is failing (obtains a new IP), this suggests you've may have two DHCP servers fighting with each other.

If you must fix your copper, then you'll start tracking back to every piece of gear between your ISP modem + machine with a problem.

On each piece of gear in the chain, check to determine location of the rogue DHCP server (which is incorrectly assigning the 2nd IP) + disable it.
0
 
8046586Commented:
0
 
Tim DawsonIT ManagerAuthor Commented:
Ok so I took the LT home and tried my network.     Same result.   The wifi is ok and I can brouse just fine.    As soon as I plug the Ethernet in to the router, there goes the web.    Turn off wifi  same thing.   So it has to be in the LT or the OS.    
IPconfig shows all is good with both connections.   :(
0
 
masnrockCommented:
You could try resetting Winsock and TCP/IP, but I don't necessarily expect that to fix things. Have you tried to obtain another driver for the LAN adapter?
0
 
Tim DawsonIT ManagerAuthor Commented:
Ok  After a 2 hour session with MSI   It turns out the solution was to uninstall both the intel and killer Ethernet drivers.   Reinstall only the killer and walla   every thing works..

So there must have been some sort of conflict with the drivers.
0
 
Tim DawsonIT ManagerAuthor Commented:
Thanks to all.  One of the weirdest issues I've seen.  First trip with MSI though....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

  • 10
  • 7
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now