Exchange 2013 - Message size limits

I'm testing sending emails to make sure they get stopped if larger than the specified size.

Internal to internal the limits on Receive Connectors are the default 35MB, however emails are still going through with attachments that are 40MB and 20MB =60MB.

I checked the Receive connector it's going through which is the Default, and that's set to 35MB limit.

Any idea why it's making it through?
Scotch TechITAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jose Gabriel Ortega CastroCEOCommented:
Ok, you configured the connectors but what about the transport config?

Please check my post in blogger: https://mcsemessaging.blogspot.mx/2016/09/exchange-connectors-to-send-and-receive.html

I think that the issue is because you aren't set the limits in the Transport configuration, give it a try into that and report us if it worked or not
0
Todd NelsonSystems EngineerCommented:
The receive connectors are not used for internal mailbox to mailbox delivery.  As Jose stated, you will need to configure the organization-wide send/receive sizes.
0
Jose Gabriel Ortega CastroCEOCommented:
Nice Detail todd I didn't realize he did changed the receive connectors :S
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Scotch TechITAuthor Commented:
Thanks, I didn't realize that internal emails didn't use the Receive connectors. I do see the test email in the logs using the Default Receive connector though, so why wouldn't the connectors limits apply? Any articles on this?
0
Todd NelsonSystems EngineerCommented:
What are the results of the following command from the article Jose provided?

Get-TransportConfig | select MaxSendSize,MaxReceiveSize

Open in new window

0
Scotch TechITAuthor Commented:
97.66 MB
0
Todd NelsonSystems EngineerCommented:
That's interesting.
0
Scotch TechITAuthor Commented:
something else interesting, this article shows the path of an internal email to another intnernal mailbox, and does say it goes through the Default Receive connector. See Step 3 towards the bottom.

http://techgenix.com/exchange-2013-mail-flow-part3/
0
MASEE Solution Guide - Technical Dept HeadCommented:
As commented above internal mail flow uses hidden connector  which is created at the time of installation not Default or Client connector.
Default receive connector accepts connections from other Hub Transport servers/Edge Transport servers.
0
Scotch TechITAuthor Commented:
Ah, that makes sense, but why do I see the email in the Default Connector logs?
Also, how can I see this hidden connector and check the configs?
What is the recommended way to limit the size in internal emails?

thank you
0
MASEE Solution Guide - Technical Dept HeadCommented:
The best option is to set transport config as commented by Todd above
0
Jose Gabriel Ortega CastroCEOCommented:
You are just running circles within the same answer I've proposed in the 1st comment bud. Please read the post.
2
Scotch TechITAuthor Commented:
LOL, yea I feel like I'm in a race by myself. Thanks guys
0
Jose Gabriel Ortega CastroCEOCommented:
haha np :)
0
Jose Gabriel Ortega CastroCEOCommented:
Please remember to mark the answers that helped you to close the question. thank you
0
Scotch TechITAuthor Commented:
Thanks Jose, I'll gladly mark your answer. But I still don't understand why internal emails make it through when they're above the size limit of the Receive connector that it is clearly going through. I understand there is a hidden Send connector, but that doesn't account for this. I understand your suggestion about setting the the Transport config at the Org level will fix this but I'd like to understand it, i just don't understand why it's not being blocked due to the Receive connector limit. Could it be that Internal to Internal emails don't get limited by the Receive connectors?
0
Jose Gabriel Ortega CastroCEOCommented:
You would need to go and read the documentation to check the reasons why.

https://technet.microsoft.com/en-us/library/bb124345(v=exchg.160).aspx
https://support.microsoft.com/en-gb/help/322679/how-to-set-size-limits-for-messages-in-exchange-server

You need to read the whole thing to understand how to set and manage connectors and how and when they work.
0
Scotch TechITAuthor Commented:
I have found the reason. FYI,

It does use the Default Receive connector, but internal emails are assigned specific permissiosn because they have been authenticated.

The specific permissions for this is: BypassMessageSizeLimit

I found this in the Protocol logs. I believe by adding the Exchange Servers group it add this and other permissions.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.