My iPhone is reading my wpa/wpa2 mixed wi-fi network as a wep network and will not connect

I have reset all devices and still the issue persists. All my android devices lap top roku dish boxes and printer connect with no problem. But every apple device iPhone nanda iPad say the wpa/wpa2 Wi-Fi network is a low security wep network and will not connect.
Thomas R.Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DamianIT incCommented:
Could be a neighbor screwing with you in order to get your WPA password!?

Change the SSID, and check that there is no longer the old name being broadcast.

But also, you should just be using WPA2, get rid of the mixed business and use AES.
masnrockCommented:
WPA is a low security network type at this point. Dump it and stick with WPA2 unless you have no choice for certain devices.
☠ MASQ ☠Commented:
Which legacy devices are you running that need WPA?  Check they are using AES and not TKIP if you're in mixed mode as your iPhone will look at the security of the most vulnerable connection.  Your phone will see a WPA/TKIP connection as no more secure than WEP.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

JohnBusiness Consultant (Owner)Commented:
Perhaps reset your Router and then on the iPhone, reset Network Components. Now try connecting with higher security. My iPhones SE here both connect with high security.
btanExec ConsultantCommented:
Do consider updating the phones to address the KRACK Wi-Fi vulnerability. This affects all WPA2.
e.g. IOS patch 11.1
e.g. Android patch on 6 November
Consider having Have the Android and Apple forget the connected SSIDs and attempt a new discovery.
For the discovered SSID, check the setting to ensure it goes for WPA2 minimally.
Avoid all weak cipher such as WPA and WEP and TKIP setting.

Also note that though WPA2 can be more secure with use of AES algorithms and CCMP (Counter Cipher Mode with Block Chaining Message Authentication Code Protocol) as a replacement for TKIP. However, TKIP is still preserved in WPA2 as a fallback system and for interoperability with WPA. If the broadcast SSID allow only the weaker setting then likely the alert are true otherwise there may be other fake AP trying to spoof the same SSID but using a weaker setting.
JohnBusiness Consultant (Owner)Commented:
Agree although my phones were connecting securely prior to IOS 11. I have the newest version OS IOS installed
Jackie ManIT ManagerCommented:
Post back the brand and model of your router.

You might need to buy a new router if your current one is outdated.
JohnBusiness Consultant (Owner)Commented:
I use Cisco Wi-Fi routers and all have provided high security to my phones.
Thomas R.Author Commented:
The router is a brand new netgear had it less than a week. It came directly from AT&T.  Unfortunately I have to run the mix for certain devices. The only devices I am having this issue with are the apple products. One is an iPhone 5 the other is an 8. Also it is not a neighbor messing with us as our closest neighbor is 5 miles away. I had to change the settings to the wifi along with the SSID and password. As I said it is a wpa/wpa2 network iPhone are reading it as wep. I have reset the devices and the Wi-Fi several times to no effect
JohnBusiness Consultant (Owner)Commented:
That router should provide higher security to iPhones. Can you update the firmware? New routers often have out of data firmware
btanExec ConsultantCommented:
Disable the IPV6 on the router and set it to set it to auto detect. Also I understand there maybe a WMM setting which you may consider enabling it (sort of Qos similar). Some has said to disable as devuce may experience slowness though. Also as John mentioned l, update the firmware and also please change all the default account password.
Jackie ManIT ManagerCommented:
What is the model no?
David Johnson, CD, MVPOwnerCommented:
What you are experiencing is an IOS limitation.  You will need a separate WIFI access point that supports WPA2 for the newer Iphone IOS's
Thomas R.Author Commented:
My thanks to everyone for the advice! I did manage to to resolve the issue by setting the Wi-Fi to wpa2 with 11g 11b & 11n mixed disabling the ipv6 and updating the firmware. Again thank you everyone for the advice

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
btanExec ConsultantCommented:
For author advice.
btanExec ConsultantCommented:
Possible means of checking and suggested means to lead to solution
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iPhone

From novice to tech pro — start learning today.