Cannot manually select Wifi networks to connect to in Windows 7

My wireless icon is missing from my systray notifications area.

I have tried going to 'Control Panel\All Control Panel Items\Notification Area Icons\System Icons' and here the selection for the Network icon is set to off and greyed out, so I cannot choose anything else.

I have tried both option 1 and option 2 in these suggested solutions:
https://www.sevenforums.com/tutorials/19085-system-icons-enable-disable.html

Also tried:
sfc /scannow


Suggestions?
LVL 2
itniflAsked:
Who is Participating?
 
Hello ThereSystem AdministratorCommented:
Hope this helps:

1.      Open regedit
2.      Navigate to the key "HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion \TrayNotify"
3.      Delete the values "IconStreams" and "PastIconsStream"
4.      Restart explorer: Open up the Task Manager and kill "explorer.exe"
5.      Click "New Task..." and type "explorer.exe"

Also you might try:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
To Enable the Network Icon - Right click on HideSCANetwork and click on Delete

But first check if you can see network adapter(s).

Also I found this article but I am not sure if it will work for you.
0
 
JohnBusiness Consultant (Owner)Commented:
Go to Device Manager. Is the Wireless Device apparently working?  

Download the driver for it, uninstall it, restart and install the newest driver. Restart after than and see if it shows up.
0
 
Hello ThereSystem AdministratorCommented:
Also try to disable your network adapter and allow it back.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Tom CieslikIT EngineerCommented:
Go to Control Panel
Display all icons then click on Notification Area

Check if in notification your network is set to Show icon and notification

Capture.JPG
0
 
David Johnson, CD, MVPOwnerCommented:
if this is a laptop many have a Fn+<somekey> that disables Wireless (check your manual) also ensure that the wireless adapter is enabled in network connections
0
 
JohnBusiness Consultant (Owner)Commented:
Have you (itnifl) tried any suggestions here?  Normally uninstall / updating / reinstall the driver fixes all ills.

Is the card even working?  My first question to you here.
0
 
itniflAuthor Commented:
Yes, the wifi network adapter works. It automatically connects to the Wifi networks I have previously configured it to auto connect to. It receives an IP address, seen with ipconfig. I simply  cannot see the tray icon.

I have tried enabling and disabling the network adapter, and tried restarting the laptop.

Answer to Comment ID: 42414718:
This is already described in the question. Kindly see the question text.

Answer to Comment  ID: 42414867:
I will try this now.

Answer to Comment ID: 42414899:
I will try this next.
0
 
itniflAuthor Commented:
After trying what is described in Comment ID: I42414867,  still have the same problem.

'Control Panel\All Control Panel Items\Notification Area Icons' does not even display the network icon as an option, and 'Control Panel\All Control Panel Items\Notification Area Icons\System Icons' has the same status as described in the question.

Moving to Comment ID 42414899, trying a reinstall of the network drivers.
0
 
itniflAuthor Commented:
Result from Comment ID 42414899:
After uninstalling the Wifi adapter and it's driver, then installing the newest driver downloaded prior to this from Intel, the problem with the systray icon is still there and exactly as described so far. I have also lost the profile that was attached to the Wifi adapter with cached wireless networks, so Windows no longer connects automatically when known networks are in range, because they are not known any more. I have tried manually adding them in the list of possible networks to connect to automatically, but when the connection is made, a dhcp address is never received. Which is not a problem with the network, it works fine for everyone else.

Considering reinstallation with an upgraded OS. Using Windows 7, have Windows 10 available.
0
 
itniflAuthor Commented:
I disabled all protocols attached  to the Wifi card that were related to Virtualization and vpn software, now the Wifi adapter can connect automatically again to the networks I have specified in the list of known networks. But the network tray icon is still no where to be seen, same status as before.

Network adapter
0
 
JohnBusiness Consultant (Owner)Commented:
You have Virtual Box and VMware both installed. Try removing both and installing only one.

Considering reinstallation with an upgraded OS. Using Windows 7, have Windows 10 available.

Consider starting fresh with Windows 10, make sure the basics work, then install only what you need.
0
 
Hello ThereSystem AdministratorCommented:
Run CMD as admin:
>DISM.exe /Online /Cleanup-image /Scanhealth
>DISM.exe /online /cleanup-image /restorehealth
>sfc /scannow

Enter Safe mode. What happens?
Run Windows 10 in Diagnostic Mode. What happens?
Try another profile. What happens?

Try to disable "Fast Startup" in the shutdown options of the Power Options menu. It's weird but it might help.
Start -> Settings -> System then select Power & Sleep and scroll to the bottom and pick Additional Power settings, this opens the Power Options menu. Now select "Choose what the power buttons do" and then "Change settings that are currently unavailable". Scroll to the bottom and under Shutdown Settings untick "Turn on fast startup (recommended)".
0
 
itniflAuthor Commented:
I have now removed both Virtual Box and VMWare and rebooted.
I did run the commands above, but that has not solved the problem.
Could not find "Fast Startup" under the power options. Followed the directions, but there is no "Turn of fast startup (recommended)".

Will try Safe Mode, and another profile next.
0
 
Hello ThereSystem AdministratorCommented:
Sorry, Fast Startup option is in Windows 10.

Run this under admin in CMD:
netsh int tcp reset
netsh int ip reset
netsh int ipv6 reset
netsh winsock reset
0
 
itniflAuthor Commented:
Nah, neither "Safe Mode with Network" nor the commands above made any difference.
0
 
JohnBusiness Consultant (Owner)Commented:
You said above you have Windows 10 available and I assume by now you have checked the hardware. So back up, install Windows 10 fresh and start again.
0
 
Hello ThereSystem AdministratorCommented:
Go to Device Manager -> Wireless Card -> Properties -> see the state of the adapter... Is there anything weird? Any error?

Go to Control Panel > All Control Panel Items > Notification Area Icons section -> Reset default icon behaviors
0
 
JohnBusiness Consultant (Owner)Commented:
I think all that has been done (looking back at the very old thread)
0
 
Hello ThereSystem AdministratorCommented:
Try to connect it to any network via LAN cable. Will the icon appear?
0
 
Hello ThereSystem AdministratorCommented:
Run network adapter troubleshooter and see if it finds something.

If the issue still persists, install the driver in compatibility mode.
Most programs created for earlier versions of Windows will work in this version of Windows, but some older programs might run poorly or not at all. You can run the Program Compatibility Troubleshooter on most programs to detect and fix common compatibility problems.

Upgrading to Windows 10 is a good step forward.
0
 
Hello ThereSystem AdministratorCommented:
Please mark all helpful posts.
0
 
itniflAuthor Commented:
Never found the solution, but surely got a whole lot of good help. Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.