VLC Media Player sub title not showing

My OS is win 10 Prof 64 bit and I am tryiing to play a foreign DVD movie called Mahabaratha which is in the Indian language (Hindhi) but has English subtitles.  My player is the VLC Media Player version 2.2.6 umbrella.  
When I played initially the English subtitles showed and then it did not subsequently.  I have been meddling with the preferences, sub title, but to no results.  Maybe I am not setting the settings correctly.  
Attached is the subtitles screen, and perhaps the experts can suggest what values to use.
Also since the VLC does not play the DVD automatically, I am at a lost to select the file to play first, attached is a list of the files too.  
How and which file does one select to play the DVD.  Thank u, regards and happy holidays
videos-list.JPG
subtitle-screen.JPG
jegajothyretiredAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

8046586Commented:
Did you add the subtitle file in VLC? When you open the App in the top menu you have subtitle tab, add subtitle file
subtitle.PNG
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hello ThereSystem AdministratorCommented:
The best is to use e.g. BSPlayer (my favourite btw). You just drag and drop your subtitles and that's it. I've never had any issues with it. Just consider it.
I used to have issues with subtitles for VLC and many more video players but BSPlayer has solved it for good.
0
David Johnson, CD, MVPOwnerCommented:
or right click on the video and select the subtitle
0
RaminTechnical AdvisorCommented:
Run VLC Media Player. Insert the DVD, and it should start the video automatically. If not, click on the Media, select the Open Disc , choose the option for DVD, and then click on the Play button.  
Now you can access the DVD's menu .

2.png1.png
Now you can right click on the screen and select any language / Subtitle which is supported by that DVD.

3.png
0
jegajothyretiredAuthor Commented:
Please close this question as I do not see a button anywhere to close it. my apologies. regards
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DVD

From novice to tech pro — start learning today.