Sound not working in linux mint

I just installed linux mint on my old desktop and for some reason the sound isn't working. I am using the on-board HDMI. I updated all the drivers that were suggested but it's still not working. Everything else is great except that. If I can't get it working I am going with Ubuntu.

I am using an asrock z77 extreme 4 motherboard.
LVL 3
JoeSystems AdministratorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

65tdRetiredCommented:
head phones work?
Is the correct sound card selected for the app?
JoeSystems AdministratorAuthor Commented:
I'm an idoit... For some reason it was muted by default.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
65tdRetiredCommented:
Good find!
JoeSystems AdministratorAuthor Commented:
I didn't see the mute check mark. I am a terrible IT.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.