Exchange 2016 autodiscover issue

Hello guys,

I´m getting this error while trying to setup Outlook with autodiscover

Process w3wp.exe (FE_Autodiscover) (PID=8708). WCF request (Get Servers for sametime.cz) to the Microsoft Exchange Active Directory Topology service on server (TopologyClientTcpEndpoint (localhost)) failed. Make sure that the service is running. In addition, make sure that the network ports that are used by Microsoft Exchange Active Directory Topology service are not blocked by a firewall. The WCF call was retried 1 time(s). Error Details
 System.ServiceModel.Security.SecurityAccessDeniedException: Access is denied.

Server stack trace:
   at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter)
   at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at Microsoft.Exchange.Data.Directory.TopologyDiscovery.ITopologyClient.GetServersForRole(String partitionFqdn, List`1 currentlyUsedServers, ADServerRole role, Int32 serversRequested, Boolean forestWideAffinityRequested)
   at Microsoft.Exchange.Data.Directory.ServiceTopologyProvider.<>c__DisplayClass33_0.<InternalServiceProviderGetServersForRole>b__0(IPooledServiceProxy`1 proxy)
   at Microsoft.Exchange.Net.ServiceProxyPool`1.TryCallServiceWithRetry(Action`1 action, String debugMessage, WCFConnectionStateTuple proxyToUse, Int32 numberOfRetries, Boolean doNotReturnProxyOnSuccess, Exception& exception)

Everything in OWA works fine!

Any ideas?

Thank you very much!

Jiri
LVL 1
Jiří BenešIT SupportAsked:
Who is Participating?
 
Peter HutchisonSenior Network Systems SpecialistCommented:
1. Check all Exchange services on the Exchange servers esp the Exchange Active Directory Topology service.
2. Check IIS and WWW Publishing services are running and Default Web Site is started. Check certificates are up to date and valid.
3. Check Exchange Web Service (EWS) is working.
4. Check services are ok on the Domain Controllers and FSMO roles are ok.
5. Check DNS esp autodiscover.mycompany.com entry
5. Check version of Outlook is up to date for connecting to Exchange 2016. Apply any additional updates.
0
 
Tom CieslikIT EngineerCommented:
Try to run Microsoft connection analizer to determine if all connections settings and autodiscover is set properly
https://testconnectivity.microsoft.com/
0
 
compdigit44Commented:
Are all workstation getting this error?
Are the workstation running Outlook on the same site as the Exchange servers?
What version of Outlook are you running?
0
 
Tom CieslikIT EngineerCommented:
Best solution provided. No more other questions from author
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.