• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 184
  • Last Modified:

ip summary-address rip 0.0.0.0 0.0.0.0 in DMVPN

I am trying to understand the effect of configuring  ip summary-address rip 0.0.0.0 0.0.0.0  on the Hub router in DMVPN Network.
per the  book, Spokes should see in their routing tables the RIP default Route 0.0.0.0, but it is not the case in my LAB

Hub#sh run 
Building configuration...

Current configuration : 1636 bytes
!
! Last configuration change at 12:59:12 UTC Sat Dec 30 2017
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Hub
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 !
!
interface Tunnel0
 ip address 172.16.123.1 255.255.255.0
 no ip redirects
 ip nhrp authentication DMVPN
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 ip summary-address rip 0.0.0.0 0.0.0.0
 tunnel source FastEthernet0/1
 tunnel mode gre multipoint
 !
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 ip address 192.168.123.1 255.255.255.0
 duplex auto
 speed auto
 !
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!
router rip
 version 2
 network 1.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

Hub#

Open in new window



Spoke1#sh run 
Building configuration...

Current configuration : 1660 bytes
!
! Last configuration change at 12:42:48 UTC Sat Dec 30 2017
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Spoke1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 !
!
interface Tunnel0
 ip address 172.16.123.2 255.255.255.0
 ip nhrp authentication DMVPN
 ip nhrp map multicast 192.168.123.1
 ip nhrp map 172.16.123.1 192.168.123.1
 ip nhrp network-id 1
 ip nhrp nhs 172.16.123.1
 tunnel source FastEthernet0/1
 tunnel destination 192.168.123.1
 !
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 ip address 192.168.123.2 255.255.255.0
 duplex auto
 speed auto
 !
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!
router rip
 version 2
 network 2.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

Spoke1#

Open in new window



Spoke2#sh run
Building configuration...

Current configuration : 1660 bytes
!
! Last configuration change at 12:50:41 UTC Sat Dec 30 2017
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Spoke2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 !
!
interface Tunnel0
 ip address 172.16.123.3 255.255.255.0
 ip nhrp authentication DMVPN
 ip nhrp map 172.16.123.1 192.168.123.1
 ip nhrp map multicast 192.168.123.1
 ip nhrp network-id 1
 ip nhrp nhs 172.16.123.1
 tunnel source FastEthernet0/1
 tunnel destination 192.168.123.1
 !
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 ip address 192.168.123.3 255.255.255.0
 duplex auto
 speed auto
 !
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!
router rip
 version 2
 network 3.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

Spoke2#

Open in new window




Spoke1#sh ip route 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.123.0/24 is directly connected, Tunnel0
L        172.16.123.2/32 is directly connected, Tunnel0
      192.168.123.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.123.0/24 is directly connected, FastEthernet0/1
L        192.168.123.2/32 is directly connected, FastEthernet0/1
Spoke1#

Open in new window


Spoke2#
Spoke2#sh ip route 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      3.0.0.0/32 is subnetted, 1 subnets
C        3.3.3.3 is directly connected, Loopback0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.123.0/24 is directly connected, Tunnel0
L        172.16.123.3/32 is directly connected, Tunnel0
      192.168.123.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.123.0/24 is directly connected, FastEthernet0/1
L        192.168.123.3/32 is directly connected, FastEthernet0/1
Spoke2#

Open in new window





Thank you
0
jskfan
Asked:
jskfan
  • 4
  • 3
1 Solution
 
JustInCaseCommented:
Function of summary 0.0.0.0 0.0.0.0 rip route is to hide more specific routes that hub will learn from spokes, hub will advertise to spokes only 0.0.0.0 0.0.0.0 route and not more specific routes. On hub you should also disable split horizon on tunnel interface if you are not using summary route. Summary route will be advertised to other routers and routers will use hub as next hop. If summary route is not configured and split horizon is not disabled spoke routers would never learn each other's routes.

to speed up RIP update/reconvergence you can change timers:
router rip
  timer basic 1 5 5 10

From your output looks like something is broken try to ping from spoke to spoke and then issue commands below.

sh ip protocols
sh ip rip database
sh ip int brief
sh ip nhrp detail
0
 
jskfanAuthor Commented:
when I disable split horizon, I am able to see all RIP routes in the spokes RIP table and in the Hub RIP tables
Spoke1#sh ip route 


Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/1] via 172.16.123.1, 00:00:53, Tunnel0
      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      3.0.0.0/32 is subnetted, 1 subnets
R        3.3.3.3 [120/2] via 172.16.123.3, 00:00:53, Tunnel0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.123.0/24 is directly connected, Tunnel0
L        172.16.123.2/32 is directly connected, Tunnel0
      192.168.123.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.123.0/24 is directly connected, FastEthernet0/1
L        192.168.123.2/32 is directly connected, FastEthernet0/1
Spoke1#

Open in new window





Spoke2#sh ip route 

      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/1] via 172.16.123.1, 00:00:05, Tunnel0
      2.0.0.0/32 is subnetted, 1 subnets
R        2.2.2.2 [120/2] via 172.16.123.2, 00:00:05, Tunnel0
      3.0.0.0/32 is subnetted, 1 subnets
C        3.3.3.3 is directly connected, Loopback0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.123.0/24 is directly connected, Tunnel0
L        172.16.123.3/32 is directly connected, Tunnel0
      192.168.123.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.123.0/24 is directly connected, FastEthernet0/1
L        192.168.123.3/32 is directly connected, FastEthernet0/1

Open in new window






However when I add this command to the tunnel interface of the Hub :
ip summary-address rip 0.0.0.0 0.0.0.0

I do not see any effect of it on the Spokes. I should see a default route on the spokes routing tables. Instead it makes the exiting RIP routes on the spokes disappear:

Spoke1#sh ip route 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.123.0/24 is directly connected, Tunnel0
L        172.16.123.2/32 is directly connected, Tunnel0
      192.168.123.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.123.0/24 is directly connected, FastEthernet0/1
L        192.168.123.2/32 is directly connected, FastEthernet0/1
Spoke1#

Open in new window



Spoke2#sh ip route 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      3.0.0.0/32 is subnetted, 1 subnets
C        3.3.3.3 is directly connected, Loopback0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.123.0/24 is directly connected, Tunnel0
L        172.16.123.3/32 is directly connected, Tunnel0
      192.168.123.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.123.0/24 is directly connected, FastEthernet0/1
L        192.168.123.3/32 is directly connected, FastEthernet0/1
Spoke2#

Open in new window

0
 
jskfanAuthor Commented:
*** I used default-information originate and it worked just fine, even after I re-enabled Split horizon


Hub(config-if)#ip split-horizon 
 
Hub(config)#router rip 
Hub(config-router)#default-information originate 


Spoke2#sh ip route rip

Gateway of last resort is 172.16.123.1 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 172.16.123.1, 00:00:22, Tunnel0
      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/1] via 172.16.123.1, 00:00:22, Tunnel0
Spoke2#

Open in new window


****Now on each spoke I can see RIP default route:

I am not sure why this command below has accomplished the same thing as Default-information originate:
ip summary-address rip 0.0.0.0 0.0.0.0
0
IT Degree with Certifications Included

Aspire to become a network administrator, network security analyst, or computer and information systems manager? Make the most of your experience as an IT professional by earning your B.S. in Network Operations and Security.

 
JustInCaseCommented:
ip summary-address does not have the same effect as default-information originate.. Default-information originate will advertise default route (without ip summary-address rip configured will also advertise all other routes), while ip summary-address rip 0.0.0.0 0.0.0.0 will advertise only default route (hide topology details) through configured interface (can be more specific route if you want to like  ip summary-address rip 10.2.0.0 255.255.0.0, it does not have to be 0.0.0.0 0.0.0.0).

IP Routing: RIP Configuration Guide, IP Summary Address for RIPv2
Summarizing routes in RIP Version 2 improves scalability and efficiency in large networks. Summarizing IP addresses means that there is no entry for child routes (routes that are created for any combination of the individual IP addresses contained within a summary address) in the RIP routing table, reducing the size of the table and allowing the router to handle more routes.

Summary IP address functions more efficiently than multiple individually advertised IP routes for the following reasons:
  - The summarized routes in the RIP database are processed first.
  -  Any associated child routes that are included in a summarized route are skipped as RIP looks through the routing database, reducing the processing time required.

Cisco routers can summarize routes in two ways:
   - Automatically, by summarizing subprefixes to the classful network boundary when crossing classful network boundaries (automatic summary).
   - As specifically configured, advertising a summarized local IP address pool on the specified interface (on a network access server) so that the address pool can be provided to dialup clients.

 When RIP determines that a summary address is required in the RIP database, a summary entry is created in the RIP routing database. As long as there are child routes for a summary address, the address remains in the routing database. When the last child route is removed, the summary entry also is removed from the database. This method of handling database entries reduces the number of entries in the database because each child route is not listed in an entry, and the aggregate entry itself is removed when there are no longer any valid child routes for it.

RIP Version 2 route summarization requires that the lowest metric of the "best route" of an aggregated entry, or the lowest metric of all current child routes, be advertised. The best metric for aggregated summarized routes is calculated at route initialization or when there are metric modifications of specific routes at advertisement time, and not at the time the aggregated routes are advertised.

The ip summary-address rip router configuration command causes the router to summarize a given set of routes learned via RIP Version 2 or redistributed into RIP Version 2. Host routes are especially applicable for summarization.
ip summary-address rip 0.0.0.0 0.0.0.0 is just the least specific summarization and since there will always be at least one child route to support it - it will always be advertised when configured.
0
 
jskfanAuthor Commented:
in the configuration above when I used ip summary-address rip 0.0.0.0 0.0.0.0 under the tunnel interface of the Hub,
The spokes did not get the default RIP route in their routing tables. I used Default-information originate with RIP configuration and was able to see the RIP default route (R*)in the spokes routing tables


**I removed RIP and replaced it with EIGRP, and used ip summary-address rip 0.0.0.0 0.0.0.0
Then I check Routing tables of the spokes and was able to see EIGRP default route (D*) in their routing tables.
 

This is why I was wondering if ip summary-address rip 0.0.0.0 0.0.0.0 does not work with RIP
0
 
JustInCaseCommented:
It should work, I am not sure why it is not working.
Try on hub to add configuration details for both (default -information and summary-address)...

int tun 0
 ip summary-address rip 0.0.0.0 0.0.0.0
router rip
 defult-information originate

It should advertise default route and hide less specific routes.
:)
0
 
jskfanAuthor Commented:
will give it a try later.
Thank you
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Identify and Prevent Potential Cyber-threats

Become the white hat who helps safeguard our interconnected world. Transform your career future by earning your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now