Why when I try to scroll the data vbble;/e2/1/12/2 tbl from left to right in the table in regular reviev>?

When I open the table 'tblSilca" and scroll one side to the oters,'
When I open the table and "tblSilica1", and scroll from left to right, the error message that is attached appears.
ERROR-MESSAGE-.jpg
Silica_App---V7.accdb
cssc1Asked:
Who is Participating?
 
Gustav BrockCIOCommented:
It's not that. It's the SQL of the lookup of the field in the table.

I warned you. Lookup fields in tables will cause you nothing but trouble and wasted time.
0
 
PatHartmanCommented:
Read the message carefully.  Is that column in the query?  If not, is there any filter or sort on it that is left over from when it was in the query?
0
 
Gustav BrockCIOCommented:
It is the field WorePumpERROR where you have this SQL for the lookup with two non-existing fields:

SELECT 
   tblSilica11.ContactID, tblSilica11.EmployeeName, tblSilica11.[Employee Number], [tblSilica11].[EmployeeTitle] AS Udtryk1, [Silica11].[SS] AS Udtryk2, tblSilica11.JobClassification
FROM 
    tblSilica11
ORDER BY 
    tblSilica11.[EmployeeName];

Open in new window

I (we) have said it before: Do avoid lookup fields as they will cause nothing but trouble.
Also: Do normalize your database properly to avoid these monster tables.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
cssc1Author Commented:
Dear LVL52,
I checked the SQL statement above and added the missing fields to the tblSilica11 and still get the error "Enter Parementer Value "SS".
I think I did everything correct? At least I hope?
Can you please check my work?
Thanks
Silica_App---V7.accdb
0
 
Gustav BrockCIOCommented:
The SS field is also missing - or must be removed from the SQL.
0
 
cssc1Author Commented:
Dear LVL52,
The SS field is in tblSilica11, I have attached an image.
I have been working on this bug all night and 3 hours into today. Although I did find three other bugs that I was able to fix.

I can't seem to fix this one.
Image1.jpg
Silica_App---V8.accdb
0
 
Gustav BrockCIOCommented:
Again, in the lookup SQL for that field, you have misspelled a [tablename].[fieldname] - now as this:

[Silica11].[SS]

Open in new window

0
 
cssc1Author Commented:
Correct me if I am wrong, but the SQL refers to a query when put in SQL view?

But, the error occurs when I am scrolling the tblSilica1 not the query?  There is no SS field in tblSilica1?
0
 
Gustav BrockCIOCommented:
Yess, but you have no Silica11 table or query:

SELECT 
     [tblSilica11].[ContactID], [tblSilica11].[EmployeeName], [tblSilica11].[Employee Number], [tblSilica11].[EmployeeTitle], [Silica11].[SS], [tblSilica11].[JobClassification] 
FROM
    tblSilica11 
ORDER BY 
    [EmployeeName]; 

Open in new window

0
 
cssc1Author Commented:
Please find attached an image table "tblSilica11".

Does this mean I need a query created with the table "tblSilica11"
Image2.jpg
0
 
Gustav BrockCIOCommented:
No, it means that you have to correct the typo in the lookup SQL - you have no table/query Silica11, only tblSilica11.
0
 
cssc1Author Commented:
Do you know what field in the query "QrylSilica1" that needs the correction?
0
 
cssc1Author Commented:
I ha ve looked for the lookup field but can't find it. What table and field is producing this error?
0
 
cssc1Author Commented:
Thaks for the help and being patient with me
0
 
cssc1Author Commented:
Thanks for the help and being patient with me
0
 
Gustav BrockCIOCommented:
It is the table and the field WorePumpERROR you originally posted.
Open the table in designview, select the field, select at bottom the second tab.
The SQL is in the Rowsource:
Table
0
 
cssc1Author Commented:
Thank you Gastuv
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.