Windows 10 Time Source

Hello Experts,

Recently I have deployed a secondary domain controller (Server 2012 R2) and after that deployment, some of our PCs in the office, keep changing their time to the incorrect time. I just realized that the time on the secondary domain control is off so I fixed that and I am hoping all will come into sync shortly. However, when I run this command w32tm /query /source on all of the machines in the office I am getting wildly different results. Some say time.windows.com, others Local CMOS Time, others the secondary domain controller, and others the primary domain controller. How can I make all of the sync to the primary domain controller?

I have tried this command, net time \\ServerName /set /y but this is only temporary, it reverts back to whateer it was. What is the end all be all fix for this issue?

The PCs in the office are Windows 10 Pro.
triphenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SeanSystem EngineerCommented:
On one of those computers can you run this command as administrator:
Net time /Domain:domain.name.fqdn

along with:
Net time \computer-name

Then check this:
W32tm /query /configuration

the finally see if this one helps:
W32tm /config /update
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hello ThereSystem AdministratorCommented:
To force a computer to synchronize its time with a specific DC, you can run the Net Time command remotely or as a batch at logon:

net time \\<DC_name_or_IP> /set /y

Open in new window


w32tm /config /syncfromflags:domhier /update
net stop w32time
net start w32time

Open in new window


w32tm /resync

Open in new window


All of them should work. You can also combine them.
0
Jose Gabriel Ortega CEE Solution Guide - CEO Faru Bonon ITCommented:
With all the respect of the other answers, I'd use the DHCP (windows) option to set that instead of setting it manually


004 specifies servers that provide TIME/ITP (as per RFC 868). This is not a recommended protocol/service in a Windows environment.

042 specifies servers that provide NTP/SNTP (RFC 1769).  This is the preferred time service in a Windows environment (assuming the absence of Active Directory which maintains the time on your behalf.
Source: https://social.technet.microsoft.com/Forums/windowsserver/en-US/7e9bcc80-45ba-49f6-8b2d-c5de0915bf93/dhcp-scope-options?forum=winservergen
0
Shaun VermaakTechnical Specialist/DeveloperCommented:
Recently I have deployed a secondary domain controller (Server 2012 R2) and after that deployment, some of our PCs in the office, keep changing their time to the incorrect time.
Virtual DC? If so disable host time sync
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.