Problems opening websites within Google Chrome in Win 7 OS

A user running Windows 7 64-bit Pro is unable to open any webpages within Google Chrome.

When Google Chrome launches or when he types in web page URL addresses we get messages that say "Your connection is not private."

If we click on the Advanced button and then click the "Continue to this webpage (not recommended)" button the webpage still won't open.

I have followed the instructions found in this URL ( and have Cleared browsing data under Privacy options & reset the Chrome browser settings (following the instructions listed below).

Additionally I have run the DISM and SFC commands and have run Malwarebytes and have removed Malware.

After rebooting we are now intermittently able to successfully connect to websites with google Chrome but still continue to get this error 7 out of 10 times and there are some websites that simply won't load at all.

What else can be done to fix this issue so Google Chrome can once again be used to surf the internet?

First of all, go to Settings > Show advanced settings > Clear browsing data under Privacy options.
If clearing browsing data doesn’t help then you can reset Chrome browser settings to the default browser settings too. To reset your Chrome browser settings:

Firstly, click on the Chrome menu > Settings > Show advanced settings > Reset settings > Reset button.

IT GuyNetwork EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lucas BishopClick TrackerCommented:
This is likely due to some software on the computer, being insecure by Chrome's estimation. Basically some insecure software is trying to be a part of the connection to each web page, and Chrome is halting because of it.

Does this happen in incognito mode too? Are you running any browser extensions/plugins? Have you tried disabling your virus scanner?

In that error message, can you click on the error "NET::ERR_CERT_WEAK_SIGNATURE_ALGORITHM" and take a screenshot of all the details shown?
MacleanSystem EngineerCommented:
If the user has Kaspersky AV this will be a common issue.
There is a component from memory on the AV console which checks encrypted site certs but I forgot the exact component name
If you disable components one by one related to Encrypted Services, HTTPS, Web or anything that sounds like it might scan a site and check chrome each time then you will likely find the one which stops this alert. You can re-enable what doesn't help, and then see if you can fix the part that has an issue.
Dave BaldwinFixer of ProblemsCommented:
I'd be checking what web sites they are going to and whether their copy of Chrome is up to date.  This copy is version 63.0.3239.132 updated just minutes ago.  It could be that the web sites need to update their SSL/TLS certificates.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

IT GuyNetwork EngineerAuthor Commented:
This happens no matter which websites we go to.

This computer has never had Kaspersky installed and also has all of its plugins & extensions disabled.
Lucas BishopClick TrackerCommented:
In that error message, can you click on the error "NET::ERR_CERT_WEAK_SIGNATURE_ALGORITHM" and take a screenshot of all the details shown?

Have you tried disabling your virus scanner?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MacleanSystem EngineerCommented:
4 things I would try.

1] Reset Netsock: From elevated CMD prompt type netsh winsock reset and press enter, then reboot.
2] Clear Cert Cache: Close browsers. Then from elevated CMD prompt type certutil -urlcache * delete and press enter.
3] Reset chrome using Google's Cleanup Utility
4] Logon as another user on PC (Create test account if needs be) and see if same problem occurs if the above 3 options failed. If it works, I'd be tempted to recreate user profile.
David Johnson, CD, MVPOwnerCommented:
is the computers date set correctly?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.