Server 2016 shadowing RDP sessions: Shadow Error

I have for many years been using the following command to shadow RDP sessions on our Terminal Servers:
  C:\Windows\System32\mstsc.exe /control /noconsentprompt /shadow:9

However on Friday I noticed that this stopped working. When I run the command I receive a small window titled "Shadow error" which states "Unspecified Error". This happens on both of our Server 2016 terminal servers. I have already run RSOP to confirm that the correct Group Policies are still being applied. The setting "Sets rules for remote control of Terminal Services user sessions" is the same as it has always been, at "Full Control without user's permission". I am executing the command as the domain administrator and have full rights. Nothing has changed that I know of, except that on Friday we had those out-of-band updates from Microsoft pushed out to address Spectre and Meltdown.

Is anyone else out there experiencing this problem? Any ideas for a fix? There is nothing being logged to event viewer for me to troubleshoot.
shadow-error.PNG
LVL 1
AaronSSHIT ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Try starting a Shadow Session from within Server Manager. Does it work?
0
McKnifeCommented:
Same for me. But it still works to connect from an elevated task manager - as long as you have the password of the user...
0
AaronSSHIT ConsultantAuthor Commented:
Philip I receive the same error message from within Server Manager. Whether I check the box for consent or not, and whether I try to Control or just View, Server Manager displays the same "Unspecified Error".

McKnife - It is good to know you are seeing the same error. When I search the web for this, not a lot comes up, but I did find a few others who had the same problem starting just last week. I'm beginning to think there was something in those out-of-band updates from Microsoft which broke Shadow functionality in Server 2016.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

McKnifeCommented:
Aaron, I have seen this error for months, if not years. Since only a people use shadowing, it could very well be that it went unnoticed for quite some time. On Win10 v1703 and 1709x64, we cannot shadow sessions either ("unspecified error"), it is still possible on 32 Bit Win10, though!
0
AaronSSHIT ConsultantAuthor Commented:
That is interesting about 32bit Win10. I have never used shadowing on Win10, so I can't speak to that. But I have been using shadowing daily on Server 2012 for several years and Server 2016 for several months. This error just cropped up on Friday and has broken my otherwise reliable support tool.
0
McKnifeCommented:
Setup a server 2016 RTM VM and see. While setting it up, deselect to search for updates during the installation phase (or disconnect it from the network). The test to confirm your findings.
0
AaronSSHIT ConsultantAuthor Commented:
McKnife, I did as you said with a clean install of Server 2016 RTM in a VM. I joined it to the domain and put it into the same OU as the other Terminal Servers to ensure the same policies are applied.

2016 RTM with no updates: shadowing works fine.
2017-12 update installed: shadowing still works fine. [1607 - 14393.1944]
2018-01 update installed: shadowing is broken. [1607 - 14393.2007]

It is most definitely KB4056890 that breaks shadowing.
https://support.microsoft.com/en-us/help/4056890/windows-10-update-kb4056890
0
McKnifeCommented:
Interesting. I could have sworn that I saw that error on 2016 before (2016/2017). But maybe I confuse this with win10.
So you found it - file a bug report with Microsoft support (and tell them by the way that it is similar with win10).
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
I'm seeing reports in other places about this. It's looking to be a confirmed bug with the patch.
1
AaronSSHIT ConsultantAuthor Commented:
Ok. Waiting to see if the next Windows Update fix this, will update accordingly.
0
McKnifeCommented:
Report the bug. If you prefer to wait, you'll wait forever. Techniques that are rarely used will rarely be serviced.
0
AaronSSHIT ConsultantAuthor Commented:
I do not know how to report a bug to MS -- I thought you need to be set up with an MSDN account. Do you know how to submit one to MS?
0
McKnifeCommented:
Are you a volume license customer? (Server 2016 VL)?
0
AaronSSHIT ConsultantAuthor Commented:
Yes, we use a VLK to activate.
0
McKnifeCommented:
Then you have an ongoing support entitlement as part of your VL agreement for as long as its active. Please inform yourself about the license benefits. You will be able to get in touch with support via VL service center https://www.microsoft.com/Licensing/servicecenter/home.aspx
0
AaronSSHIT ConsultantAuthor Commented:
I just spent 20 minutes to locate and enable my VL access to support, only to find out that the third web page in ticket submission process doesn't work: "sorry, the page you requested is not available". I will not be wasting more of my time trying to report this to MS -- I have other work that needs done.
0
McKnifeCommented:
Your choice.
But please don't forget about this question and close it some day.
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Updates get free bug support. A call into Microsoft's support line with the bug is the way to go to create a ticket.
1
AaronSSHIT ConsultantAuthor Commented:
I did finally get this submitted to Microsoft. They were able to replicate the issue and confirmed it is a bug. I'll update this ticket when they provide a fix.
1
David ParmentierSupport HelpdeskCommented:
Hello
I confirm the same problem also.
Windows Server 2016 - Update KB890830 du 09/01/2018

"Erreur de copie Shadow"
Error.JPG
1
fairtechCommented:
Having the same issues, but I use the Terminal Server Manager from Lizard Systems. Worked perfect for months and I installed ms updates on 14Jan2018 and don't work.
Capture.JPG
1
Ryan RoodCommented:
Confirmed as well. Removing KB890830 fixed my issue.
0
AaronSSHIT ConsultantAuthor Commented:
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
arash hamedaniCommented:
Confirming KB4057142 fixed the issue.
1
AaronSSHIT ConsultantAuthor Commented:
fixed by patch
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.