.DLL issue on a RDS VM.

I was tasked to install programs on a VM that will be our new RDS (aka Terminal Server). Its a Windows Server 2008 R2 Enterprise VM.

I installed Office 2016 but any time I try to open, remove, do anything with the program I get...

"The program can't start because api-ms-win-crt-runtime-l1-1-0.dll is missing from your computer. Try reinstalling the program to fix this problem."

I've tried several things I have found including updating Microsoft Visual C++ Redistributable which would only install 2010. Installing 2015 or 2017 fails. Uninstalling the Office via command line also did not work.

Before we recreate this VM I wanted to see if anyone has experienced this issue before and has a resolution as I feel like attempting to install Office again will result in the same issue.

Thank you.
alfred_itVP, ITAsked:
Who is Participating?
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
We've had issues with installing Office 2016 and Microsoft Windows 2008 R2, we switched the OS to Server 2012/2016.

We would recommend, you create a new Windows 2008 R2, test Office 2016 installation before applying updates.... - this worked for us.

After we brought 2008 R2 up to date, and we had issues again.

BUT.... on occasions clients complain in their large farms, they also have issues with this DLL, they role out a new server....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.