• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 102
  • Last Modified:

VMware host and Hyper-V hosts guests can't communicate

Hi all. I have 2 physical boxes running 2012 R2.

Box one 192.168.0.249 SM 255.255.255.0 GW 192.168.0.1 running VMware workstation with 2 ESXi virtual hosts. Also I have vSphere which has the 2 hosts added to a cluster and then i created a couple of VMs inside the cluster. VMs in the cluster can can ping host and get to the internet.
IP range for VMware workstation is  (please attached image vmip)

Box two IP 192.168.0.250 SM 255.255.255.0 GW 192.168.0.1 running Hyper-V with several VMs including lab DCs. For Hyper-V network pleased see image hvip.

Problem. VMs on box 1 (vmware) can ping and communicate to VMs on box 2. I can even join VMs to the domain whereby they have to communicate with a DC on box 1, the Hyper-V server.

VMs on box 2 however, the Hyper-V guests cannot ping, map drives to VMs on box 1.

There are no firewalls running

I believe the VMs on box 1, the VMware server can ping because the default network has them bound to the physical host card. So the vmware network is taking care of the natting. What i can't figure out is what i have to do the network on the Hyper-V host to make those VMs see the VMs on the VMware host.
Any pointers appreciated.
vmip.JPG
hvip.JPG
0
Jason Thomas
Asked:
Jason Thomas
  • 10
  • 5
1 Solution
 
David Johnson, CD, MVPOwnerCommented:
the problem is the NAT connection change it to an bridgedl connection
0
 
Jason ThomasAuthor Commented:
Hi David. Change to bridged on Hyper-V host or VMware?
0
 
David Johnson, CD, MVPOwnerCommented:
vmware as hyper-V is already using an external connection
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Jason ThomasAuthor Commented:
Hi David. So the 2 esxi hosts appear to be using NAT network, i need to change this to NAT8 under each one's settings. Is that correct?
0
 
Jason ThomasAuthor Commented:
Here is the network setting for one of the ESXi hosts. Please see attached.
newvm2.JPG
0
 
Jason ThomasAuthor Commented:
Sorry David. I just re-read your response, properly this time :) I'll make change now.
0
 
Jason ThomasAuthor Commented:
As soon as i switch ESX1 to use bridged, vSphere looses contact and i can no longer access the VMs. Would i not need to change the IP addresses of the ESXi servers to match that of the 192.168.0.0 network?
0
 
David Johnson, CD, MVPOwnerCommented:
everything has to be on the same network subnet or they will use the default gateway
0
 
Jason ThomasAuthor Commented:
To do that though, should i have to change the NAT 8 IP range that is auto allocating IPs to the VMs? I ask because at the moment the ESXi servers get their network settings from that DHCP range.
This is where i find VMware network settings confusing. I know i can change them manually, but why would i need to because despite getting 192.168.213.0/24 address, they can hit my router on 192.168.0.1 ?
0
 
David Johnson, CD, MVPOwnerCommented:
that is because your router is the default gateway
0
 
Jason ThomasAuthor Commented:
Understood. But VMware dhcp is allocating  192.168.213.124 (example, 255.255.255.0 GW 192.168.213.2
So with that gateway on the VM, how are they able to get to the internet via 192.168.0.1 ?
0
 
Jason ThomasAuthor Commented:
And one other thing. Those Vms on the Vmware with 192.168.213.0 addresses can ping vms on the hyper-v host with 192.168.0.0 addresses. It's the Hyper-v VMs that can't ping the Vmware VMs despite being internet accessible.
0
 
David Johnson, CD, MVPOwnerCommented:
it is because of NAT, one can connect outbound since they initiate the conversation but incoming started conversations don't know where to go
0
 
Jason ThomasAuthor Commented:
Makes sense thank you. But not sure where that leaves me now. If i change the IP address of both the ESXi host and it's VM to that of 192.168.0.0 the ESI hosts drops of the network - understandably. But when i add it back with the new IP address it fails to connect.
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Turning the Windows Firewall off places it in a form of "Limp Mode" that can actually lock things down.

Leave the WF _on_ and enable both Logging and Pop-Up in the settings or via Group Policy (what we do).

Then check the Firewall Log to see if it is actually dropping packets.

An additional benefit of leaving it enabled is to see if packets are indeed reaching the intended host in the first place. If not, then one gains a better insight into where the problem lies.

Please don't disable the Windows Firewall.
0
 
Jason ThomasAuthor Commented:
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 10
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now