SSRS 2016 Connection/Permission Error

I'm getting a connection error when trying to render a report using SSRS 2016 Report Manager.  Here is my setup:

For testing purposes, I installed SQL Server 2016 Developer on a Windows 10 Professional laptop.  As part of the SQL Server installation I installed SSRS 2016, on the same laptop.  Then I configured SSRS 2016 and everything seems good to that point.

I created a new data source (DataSource1) and a test report in Visual Studio.  The report previews perfectly while in Visual Studio, so I deployed both the data source and the report to the Report Manager.  

I see the report and data source when I open Report Manager web page.  However, when I run the report I get the following error:

"...Cannot create a connection to data source 'DataSource1'. (rsErrorOpeningConnection).  A network-related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible..."


When I test the data source in Visual Studio it works.  When I test the data source from the Report Manager web page I get the same error as above.  

It seems simple enough but I can't figure out what the issue is.  I am using Windows authentication and I'm the admin for the laptop as well as the SQL instance.

Any help would be appreciated.  Thanks.
CalBobAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CalBobAuthor Commented:
I found out that SSRS 2016 is set up slightly different in terms of data sources in Report Manager.  If you are using a Windows account (or Windows Authentication) you have to select it from a drop-down list.  In earlier versions, there was a checkbox under the credentials you enter - so I missed the change.  

I have included a screen shot of the change and solution for me.  Now it seems simple.  Thanks for you suggestions.
ScreenShotSnipet.png

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CalBobAuthor Commented:
I found the problem and included a screen shot and explanation.  Thanks.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SQL

From novice to tech pro — start learning today.