Error installing WSUS 3 SP2 on Windows Serve 2008 R2

I am getting the following errors when I try installing the WSUS 3 SP2 on a window server 2008 R2.

2018-01-09 23:33:29  Error     MWUSSetup          InstallWsus: MWUS Installation Failed (Error 0x80070643: Fatal error during installation.)
2018-01-09 23:33:29  Error     MWUSSetup          CInstallDriver::PerformSetup: WSUS installation failed (Error 0x80070643: Fatal error during installation.)
2018-01-09 23:33:29  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup failed (Error 0x80070643: Fatal error during installation.)
2018-01-09 23:33:44  Error     MWUSSetup          DoInstall: Wsus setup failed (Error 0x80070643: Fatal error during installation.)

Any thoughts?

Thanks,
Tharaka
TREOSTAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
did you specify SQL or WID for the database?
TREOSTAuthor Commented:
I used WID database and I am running .NET framework 4.7...

Thanks,
Tharaka
Seth SimmonsSr. Systems AdministratorCommented:
I am running .NET framework 4.7...

uninstall it and try again
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

TREOSTAuthor Commented:
Uninstall .NET framework and try again? Cuz it didn’t install WSUS
Seth SimmonsSr. Systems AdministratorCommented:
remove .net 4.7
there have been a number of conflicts between that and some windows components
saw something in the last week or two on server 2012 where someone couldn't install a windows feature; after removing .net 4.7 it worked
i have not pushed it out at my office.  4.6.1 is ok

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TREOSTAuthor Commented:
that worked! thanks for your help!

Thanks,
Tharaka
PberSolutions ArchitectCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Accept: Seth Simmons (https:#a42431163)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

Pber
Experts-Exchange Cleanup Volunteer
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.