• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 272
  • Last Modified:

Microsoft Edge and Photos on Windows 10 not printing to networks printers

Good morning to whom this may concern,

We're currently in the process of upgrading our users OS from Win 7 to Win 10.
Some users have reported that when they've attempted to print images or documents from Microsoft Edge, or images from Photos on their system, the print option on their system is fine. However, when they go over to one of the network printers (Canon C5250i), nothing appears.
Other web browsers work fine (IE, Chrome, Firefox and Safari) and also users who still have Windows Photo Viewer installed on their system, are able to print from that.
I've done a test print to a local printer, from Edge and Photos, but they seem to print fine.

Has anyone else experienced this issue, and how they were able to resolve this?

Thanks for any help you can provide.
0
Scott Danells
Asked:
Scott Danells
  • 7
  • 2
5 Solutions
 
Hello ThereSystem AdministratorCommented:
Check for updates and reset Edge to its defaults.

Not mine:
Well to reset Edge I have found deleting
C:\Users\%username%\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe
Clears it, including favorites and all. That does break Edge for the user. To get it running again from an admin Powershell prompt;
Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" -Verbose}

Or go to Apps and Features -> Click on Microsoft Edge -> Advanced options -> Reset (Repair)
0
 
Hello ThereSystem AdministratorCommented:
Then run DISM /Online /Cleanup-Image /RestoreHealth as admin
0
 
Scott DanellsAuthor Commented:
Good afternoon Hello There,

Thanks for commenting so quickly on my issue.

Unfortunately, this doesn't appear to have worked.

I find it odd, that it's only Edge and the Photo application that has this issue.
This now includes laptops upgraded from Win 7 to Win 10, but also freshly imaged machines with Win 10 and these applications on them.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Scott DanellsAuthor Commented:
Also, I just realised that the datatype that is being sent to our printer via Edge and Photos is: XPS2GDI
Where as the datatype for prints via Chrome etc is: RAW

I assume this is probably the issue.
0
 
Hello ThereSystem AdministratorCommented:
From another discussion:


Hello,

I've had similar issues changing the default printer settings with Edge. It looks like it's more of a problem with the basic printer settings and not explicitly with edge. Microsoft could definitely do more to make this intuitive. To resolve -

Press Windows+S and then click on 'settings'->'Devices and Printers'. You can probably just do a search for devices and printers also.

Then, right-click on your printer and select  'Printing Preferences'. The default printer settings should appear. The default 'paper size' is 'Same as Original'. Apparently Edge interprets this to be the A4 size. Just change the paper size setting to 8 1/2x11 to resolve. You can also set 2 sided printing and other things from here.

I'd say it's Edge behavior and you can only make any difference by changing printer settings.
0
 
Hello ThereSystem AdministratorCommented:
This is also possible solution:

When printing (UFR II, PS or PCL) from Win 10 client PC using any native Win 10 application like Edge or Photo viewer to a device with the Dept. ID management turned ON, The Dept. ID screen is not displayed on the client station. Printing job locks up in the queue and requires server re-boot. All other applications are printing fine.

The issue is reported right after Microsoft Security Patch for Windows Print Spooler Components MS16-087 was implemented to the server.

Workaround:

The solution found in following two steps:

Step 1: At Win 2012 Server Print Management > Driver > Isolation > the setting mode is changed from default"Shared" to "None".

Step 2: In the Driver Properties > Sharing > De-select "Render print jobs on client computers" and then select it again, Apply and close.
0
 
Hello ThereSystem AdministratorCommented:
Also make sure you are running the latest Win10 v 1709. (winver command)
0
 
Hello ThereSystem AdministratorCommented:
Why do you need to use Edge while many better browsers are available?

Also try Ctrl+P shortcut.
0
 
Hello ThereSystem AdministratorCommented:
Many more suggestions are here.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now