VM changed to /vmfs/volumes/xxxxx after storage power off - how to recover?

Hi
Using vSphere 5.5, with 3 esxi .
in Esxi1, i have a VM stored in a synology nas, called Unitrends. Yesterday, after the NAS had a power shortage, when i tried to restart the machine (without knowing at the time that the storage was not available), the name changed to /vmfx/volumes/530773a-4e463....... (inaccessible).
I powered back on the Synology NAS, and checked that the All Path Down error messages are cleared, and can browse the datastore. Still, i don't know how to rename this back to it's original name, and power on the machine...

Thanks
Jaime
LVL 2
GreatSolutionsC.I.OAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
1. Remove this entry from the inventory - right click remove from inventory.

2. Browse the datastore, and re-add the Virtual Machine to the inventory.

see Step 6 in this EE Article I wrote

HOW TO: Clone or Copy a virtual machine in VMware vSphere Hypervisor ESX/ESXi 4.x or ESXi 5.0

and when your power on the VM, you may get this message, see article

HOW TO: Select the right answer to "I Moved It" or "I Copied It" in VMware vSphere (ESXi)
0
GreatSolutionsC.I.OAuthor Commented:
Hi thanks for jumping in.
I tried removing from inventory in order to re-add it before i posted my question. When trying to remove i got the error message "A general system error occurred: invalid fault" call "VirtualMachine.Unregister"...failed
0
GreatSolutionsC.I.OAuthor Commented:
Alright googled a bit and could remove it from the inventory after running a services.sh restart in the esxi.
Now, when i want to add it back to the inventory, i get the following error message:
"Unable to access the virtual machine configuration: invalid datastore path ds:///vmfs/volumes/53707731-4e....." which is really weird because when i browse the datastore it all seems good. I think somewhere when the Synology was powered off vmware renamed the path to that long ID  while what i see in the datastore is the original vm name
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
That path is the real non friendly name

There is nothing still try to access this volume

ISO's CD-ROM floppy disks

Check data store inventory
0
GreatSolutionsC.I.OAuthor Commented:
I didn't understand your last message. If i browse the data store inventory i see no vm in it, since i successfully removed the old one from the inventory. The problem is now trying to re-add it.
Is there some way i can edit the vmx in the datastore and set the correct name, or something like that?
0
GreatSolutionsC.I.OAuthor Commented:
Finally managed to fix the remaining  by choosing different esxi host where the datastore didn't scream :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
vSphere

From novice to tech pro — start learning today.