Powershell ISE stopped working prompt

So not sure if it related to Patch Tuesday or not, but after I updated my computer Powershell ISE stop working.
I have search the internet for fixes and tried them.
  1. MalwareBytes for Poweliks and nothing came up
  2. Installed PS 5.1
  3. Checked and confirmed that KB3163245 is installed, but this was well before I started to have this issue. I did uninstall it, but still having the same issue.

Any Ideas
LVL 26
yo_beeDirector of Information TechnologyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dustin SaundersDirector of OperationsCommented:
Anything in the Application Event logs related to the exception?  Same problem launching x86 and x64 versions?  As admin?

A side note, but I ditched ISE for Visual Studio Code as I found the interface, bug testing, and other features to be much more useful.
1
yo_beeDirector of Information TechnologyAuthor Commented:
Nothing that helps.
I did do a system restore to the right before the updates applied and I was able to access ISE, but one the updates pushed again it stopped working again.  This is leading me to believe that one of the recent updates.
0
Dustin SaundersDirector of OperationsCommented:
List of recent updates installed?
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

Dustin SaundersDirector of OperationsCommented:
And, what OS are you on?
0
yo_beeDirector of Information TechnologyAuthor Commented:
Found the culprit.
Update for Microsoft .Net Framework 4.7.1 (KB4055002)
I uninstalled this and  Powershell ISE worked again.

2018-01-12_14-20-39.png2018-01-12_13-14-01.png
0
Dustin SaundersDirector of OperationsCommented:
Doesn't look like they have a workaround to that problem other than what you did there, but they do have the Security Only patch which suggest as the alternative.

https://support.microsoft.com/en-nz/help/4055269/security-only-update-for-net-framework-3-5-1-4-5-2-4-6-4-6-1-4-6-2-4-7
0
yo_beeDirector of Information TechnologyAuthor Commented:
That was not the one I removed.  That one did install and actually is not listed in the updates that I can uninstall.
0
yo_beeDirector of Information TechnologyAuthor Commented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
yo_beeDirector of Information TechnologyAuthor Commented:
Turns out that WPF is affected by .net 4.7.1  and buy unistalled 4.7.1 and reinstall 4.7 Powershell ISE worked
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Powershell

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.