Cannot get Windows update to run on Exchange server

For some reason all of a sudden I cant get updates to run on our 2012 R2 server running exchange 2013.
Every time I try to run it I get the error   8024402F.
I tried running the troubleshooter and I tried deleting the files in the folders on the C drive for the updates but it still won run..
LVL 1
vmichAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CESNetwork AdministratorCommented:
Try this command that rebuilds WMI repository:

cd C:\Windows\System32\wbem\AutoRecover\
for /f %%s in ('dir /b *.mof *.mfl') do mofcomp %%s
0
vmichAuthor Commented:
CES,
Not sure what you are saying to run?
Can you verify the command?
0
CESNetwork AdministratorCommented:
I have run this on several servers.  Run it from an elevated command prompt.  Once it finishes check for updates again
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

vmichAuthor Commented:
CES,
This is what I get when I run it....
%%s was unexpected at this time.
0
CESNetwork AdministratorCommented:
oh sorry,  I pulled that from a batch file, run it without the second %:

for /f %s in ('dir /b *.mof *.mfl') do mofcomp %s
0
vmichAuthor Commented:
Ok I got the command to run thanks, but I am still getting the same error when I try to run the updates.
0
Domenic DiPasqualeSystem / Network AdministratorCommented:
Is one of the updates your attempting to install one of the January monthly updates? Microsoft has started releasing updates that require AV vendors to be able to create a certain reg key (Microsoft is checking AV compatibility, something to do with accessing the Windows kernel memory). If an AV is not installed on the server, you may need to manually create the registry key to "Qualify" for future updates. Please review the link below:

https://support.microsoft.com/en-us/help/4056895/windows-81-update-kb4056895

https://support.microsoft.com/en-us/help/4072699/january-3-2018-windows-security-updates-and-antivirus-software
0
vmichAuthor Commented:
Well there are two servers in the DAG and the passive server ran the updates just fine it is the active server that wont accept the updates so I don't think that maybe the issue
0
Seth SimmonsSr. Systems AdministratorCommented:
can you post \windows\windowsupdate.log ?
0
vmichAuthor Commented:
I found that there was a registry entry pointing to an old wsus server that is gone, so I removed that and reran the updates but it is still failing.
0
Seth SimmonsSr. Systems AdministratorCommented:
same error code?
did you try stopping windows update service, deleting everything in windows\software distribution folder, start windows update service and check again since you removed that registry entry?
0
vmichAuthor Commented:
Yes I did do all of that earlier but now I get the error : 80072EE2 Windows update ran into a problem
0
Seth SimmonsSr. Systems AdministratorCommented:
that is a timeout
can you check the local policy (assuming no GPO is in place for that setting) and see if anything is defined?
computer configuration -> administrative templates -> windows components -> windows update
make sure 'specify intranet microsoft update service location' is not configured which will tell it to use windows update directly
0
vmichAuthor Commented:
Well I still cant seem to get the updates to download to the server I keep getting the same error.
0
vmichAuthor Commented:
I still cannot get the updates to work on the server. Does anyone have any ideas on what I can do to resolve this.
0
vmichAuthor Commented:
well no resolution so will be calling Microsoft support.
0
vmichAuthor Commented:
got issue resolved by working with support. Had to make many changes with them to get this to work and cant recall what actually out of all the thing s they had me do, that fixed the issue.
Thanks for all of the input though to this
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vmichAuthor Commented:
got help from Microsoft support
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.