why chkdsk ?

everytime i connect a windows 10 drive to a windows 7 system - as second drive - it starts  running chkdsk
this happens also when i connect a windows 7 drive to a windows 10 system as second drive
of course - it NEVER finds an error - but it takes a lot of time
why is this? can i stop that behaviour ?  if so - tell me how please !
LVL 94
nobusAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dr. KlahnPrincipal Software EngineerCommented:
You pose some of the most interesting questions, nobus.

It would help if we knew the nature of the drives.  Are they internal connected via the motherboard, or external connected via USB?

Pure speculation:

The drives in question are external drives and were not ejected from the host system when the USB cable was detached.  This leaves the dirty bit set on the drive.  When taken to another system it sees the dirty bit and launches chkdsk.

Ejecting a removable drive
0
nobusAuthor Commented:
all connected directly to sata ports
i often connect a drive, to copy files and folders -  that's how i get to have the problem
0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
If you disconnect while on power, that might happen.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

nobusAuthor Commented:
no disconnect with power on
i know it has a dirty bit flag - but why ?? THAT is my question
0
JustInCaseCommented:
I am not sure why that is happening, I had that same issue long time ago with XP and Vista (every time when rebooted or shutdown and then boot to other OS it would perform checkdisk). At that time I found some explanation why that is happening, I tried, but I can't find it now.

Just as a side note, to mention that I noticed brand new swapfile.sys file on system drive, and in last few months it is happening that I shut down Win10, and when I power it up in the morning applications that were running previous night can be already on. Today, for start, I disabled hibernation  to see if it will happen again, or maybe swapfile.sys has something do with it.

Beside why, you asked how to prevent it. It is listed on the link above how to prevent it.
 :)
0
Dr. KlahnPrincipal Software EngineerCommented:
There was an issue some years back that I only vaguely remember.  It involved taking NTFS volumes from one system to another where the systems were at different releases of Windows.

Each system on seeing the drive would rewrite part of the NTFS header block to its own satisfaction, which resulted in the earlier release operating system being dissatisfied at seeing a higher revision level of the NTFS header structure.  It only occurred when the drive was going from a later release of Windows to an earlier release, though, if I remember right.
2
noxchoGlobal Support CoordinatorCommented:
Apparently the dirty bit is not cleared by chkdsk on these drives and thus chkdsk tries again and again to scan and clear it.
Did you perform CHKDSK x:/f or /r?
If yes and this did not help then I would use the bulky approach - copy out the data from these drives and delete the partitions - re-create them.
0
nobusAuthor Commented:
i know how to clear the dirty bit - that's not the solution
the question is how to prevent that the dirty bit gets set - then you don't have to clear it

Dr Klahn - that is my opinion also - different OS versions are the cause - but i'm not sure

Noxcho "Apparently the dirty bit is not cleared by chkdsk on these drives"  yes it is
>>  Did you perform CHKDSK x:/f or /r?  <<  i did nothing - it autoruns on startup
the rest of your comment does not help with my problem
0
NerdsOfTechTechnology ScientistCommented:
Use a Linux Live OS disc and move those files over instead. Neither chkdsk nor weird permission issues that way. Then reboot to Windows.
0
nobusAuthor Commented:
i don't need to move any files - i only want to know why chkdsk is started in that scenario
0
NerdsOfTechTechnology ScientistCommented:
Does this occur from Windows 10 to Windows 10?
What about major version differences between Windows 10 systems?
What about Windows 7 to 8/8.1 and vice-versa?
What about Windows 8 to 8.1 and vice-versa?
What about Windows 8 to Windows 10 and vice-versa?

Hypothesis: I side with Dr. Klahn and you. I think NTSF headers come into play.

So can one stop it from happening? Maybe not.

I wonder if you could bypass chkdsk as a workaround...

Using the Registry Editor before inserting the secondary drive, try:
Run regedit to open the Registry Editor and navigate to the following key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

Open in new window

Change the BootExecute entry from:
autocheck autochk * /r\DosDevice\C:

Open in new window

To:
autocheck autochk /k:D /k:E /k:M *

Open in new window

or whatever drive letters which the system might label the 'secondary drive' as, to exclude from chkdsk.

Autochk on boot is meant to catch drives with a dirty bit. I say workaround because this will prevent the system from checking that drive letter for a dirty bit in the future.
0
NerdsOfTechTechnology ScientistCommented:
Sorry for the multiple edits; Let me know if the final draft workaround above, bypasses the chkdsk on boot.
0
nobusAuthor Commented:
i don't know if it happens with other OS versions -  i don't have them to test with
bypassing chkdsk is too late - i just want to know why it runs - and if there is something i can do so it never runs anymore
btw  -i don't know the drive letters, since i hook the drives in different locations and systems

i also think its an NTFS header problem - maybe the fast start option?
1
NerdsOfTechTechnology ScientistCommented:
Some forums say that fast start could even be a major factor for this behavior. If the system sees two bootable drives, fast start being enabled will most definitely cause a chkdsk.

Re:
https://www.tenforums.com/drivers-hardware/7465-chkdsk-problem.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusAuthor Commented:
since you backed that up  with a link to others in this situation, i' take it as best answer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.