can't access windows xp share

I believe after updating windows 2010 pro, I've lost access to an old windows xp pro share on the network,  I get a message saying "you can't connect to file share because it's not secure. this share requires the obsolete smb1, which is unsafe and could expose your system to attack. your system requires smb2 or higher..." have anyone faced this?
LVL 1
jdffAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hello ThereSystem AdministratorCommented:
MS has disabled SMBv1 in Windows 10. But there is a way to re-enable it. I don't have to say it's not recommended.
0
jdffAuthor Commented:
How can I re-enable?
0
Hello ThereSystem AdministratorCommented:
From MS support:

If you try to connect to devices that support only SMBv1, or if these devices try to connect to you, you may receive one of the following errors messages:

You can't connect to the file share because it's not secure. This share requires the obsolete SMB1 protocol, which is unsafe and could expose your system to attack.
Your system requires SMB2 or higher. For more info on resolving this issue, see: https://go.microsoft.com/fwlink/?linkid=852747

The specified network name is no longer available.

Unspecified error 0x80004005


System Error 64

The specified server cannot perform the requested operation.

Error 58
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Hello ThereSystem AdministratorCommented:
Read this. It provides more info about your issue.
0
Hello ThereSystem AdministratorCommented:
Run Powershell as admin:
Enable-WindowsOptionalFeature -Online -FeatureName SMB1Protocol

OR

Programs and Features -> Turn Windows Features On or Off -> locate SMB 1.0 and enable it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hello ThereSystem AdministratorCommented:
An explanation here. It's disabled due to vulnerabilities (ransomware...).
0
JohnBusiness Consultant (Owner)Commented:
You may find other security upgrades in Windows 10 prevent connection. I tried enable SMBv1 here and still cannot connect to my XP machine. XP is now long dead so get your data from it (disk in a carrier) and forget the XP machine.
0
jdffAuthor Commented:
I don't have enough time for migration at this point, this box runs an old software so I need to get around this in the meantime.
0
JohnBusiness Consultant (Owner)Commented:
Transfer required data on a USB key. That should work fine.
0
jdffAuthor Commented:
Worked great!
0
Hello ThereSystem AdministratorCommented:
I am glad I could help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.