• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 168
  • Last Modified:

Windows XP Mode Virtual Machine not booting

Hi Everyone,
I had a client who is using Windows 7 and Windows XP Mode have their Windows XP VM stop working. I am thinking the key to solving it is the Integrated Features options which is grayed out. Does anyone know how I can make these options live so I can uncheck the selected devices?
 WinXP Mode Integration Features
0
PAMurillo
Asked:
PAMurillo
  • 9
  • 8
1 Solution
 
JohnBusiness Consultant (Owner)Commented:
1. Are you, the client, the local administrator of the machine?  You may need to be to change these options.

2. Otherwise, back up the virtual machine folder for safety and then uninstall XP Mode, restart, reinstall XP Mode and test.
0
 
PAMurilloAuthor Commented:
The virtual machine is set up  under a local administrator user account.  This computer is not on a domain.
 
I have uninstalled, rebooted,  reinstalled Windows XP Mode  then  created a new  virtual machine using the backed up  virtual machine file (I merged the parent and differential files of the WinXP VM into a single file which was my backup).  With the same result.

*This is not the same WinXP VM I mentioned in my earlier post
0
 
JohnBusiness Consultant (Owner)Commented:
What happens on this machine if you create an entirely new XP VM with XP Mode?   Does this work (be sure to move the old machine somewhere else first).
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
PAMurilloAuthor Commented:
I'll give it a try and let you know. Give me a few hours
0
 
PAMurilloAuthor Commented:
I tried creating a new VM. It got almost to the end and then gave me thisWinXP VM Creation CrashI am thinking I need to try uninstalling then reinstalling the Win XP Mode software. What do you think?
0
 
JohnBusiness Consultant (Owner)Commented:
Uninstalling and Reinstalling XP Mode was a suggestion I made at the beginning. Yes, you should try this.

Restart in between uninstall and reinstall.
0
 
PAMurilloAuthor Commented:
Update: The new VM is working. I merely started it and it opened without issue. For the new VM, the Integration Features are 'live'. Because of this, is there a .TXT or .XML  file that safes the Intergrated Features that perhaps is corrupted for the VM I am trying to troubleshoot?
0
 
JohnBusiness Consultant (Owner)Commented:
It would appear the main XP VM is indeed corrupted. Do you have a prior backup? If not, you may need to rebuild the machine
0
 
JohnBusiness Consultant (Owner)Commented:
Also look in the VM folder for a configuration file. I can edit a VMWARE configuration file. If you can find an XP Mode configuration file, post it here so it can be reviewed.
0
 
PAMurilloAuthor Commented:
I can't upload the file so I am posting the contents
<?xml version="1.0" encoding="UTF-16"?>
<!-- Microsoft Virtual Machine Options and Settings -->
<preferences>
	<version type="string">2.0</version>
	<event_logging>
		<preference_change>
			<enabled type="boolean">false</enabled>
		</preference_change>
	</event_logging>
	<hardware>
		<bios>
			<base_board>
				<serial_number type="string">8138-6487-1460-0263-8988-7770-91</serial_number>
			</base_board>
			<bios_guid type="string">{11F7BDE4-46EA-4EC8-B7FC-DF7E95E594BD}</bios_guid>
			<bios_serial_number type="string">8138-6487-1460-0263-8988-7770-91</bios_serial_number>
			<chassis>
				<asset_tag type="string">8961-2436-7177-5021-5432-6685-17</asset_tag>
				<serial_number type="string">8138-6487-1460-0263-8988-7770-91</serial_number>
			</chassis>
			<cmos type="bytes">00004000F020378002FFFF2F00FF3F1000003F00000000000031004C07070707065CFFFF208580FF03000000200C01800CFC00000000000000000000000000901A32E252580050E999E62401002784004A2080240000000000085AACFE1032547698BAE400000000000003000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</cmos>
			<time_bytes type="bytes">20001300160003170118</time_bytes>
		</bios>
		<memory>
			<ram_size type="integer">1024</ram_size>
		</memory>
		<pci_bus>
			<ethernet_adapter>
				<controller_count type="integer">1</controller_count>
				<ethernet_controller id="0">
					<ethernet_card_address type="bytes">0003FF8AF169</ethernet_card_address>
					<id type="integer">0</id>
					<virtual_network>
						<id type="bytes">55476CE31B2B4173A11E298133499427</id>
						<name type="string">Intel(R) 82579LM Gigabit Network Connection</name>
					</virtual_network>
				</ethernet_controller>
			</ethernet_adapter>
			<video_adapter>
				<vram_size type="integer">16</vram_size>
			</video_adapter>
			<ide_adapter>
				<ide_controller id="0">
					<location id="0">
						<drive_type type="integer">1</drive_type>
						<pathname>
							<absolute type="string">C:\Users\Erik\AppData\Local\Microsoft\Windows Virtual PC\Virtual Machines\Windows XP Mode.vhd</absolute>
							<relative type="string">.\Windows XP Mode.vhd</relative>
						</pathname>
						<undo_pathname>
							<absolute type="string" />
							<relative type="string" />
						</undo_pathname>
					</location>
				</ide_controller>
				<ide_controller id="1">
					<location id="0">
						<drive_type type="integer">2</drive_type>
						<pathname>
							<absolute type="string">C:\Program Files (x86)\Windows Virtual PC\Integration Components\IntegrationComponents.iso</absolute>
							<relative type="string">..\..\..\..\..\..\..\Program Files (x86)\Windows Virtual PC\Integration Components\IntegrationComponents.iso</relative>
						</pathname>
					</location>
				</ide_controller>
			</ide_adapter>
		</pci_bus>
		<standard>
			<name type="string">Virtual PC 7</name>
			<version type="string">0001.0000.0000</version>
		</standard>
		<super_io>
			<floppy id="0">
				<pathname>
					<absolute type="string" />
				</pathname>
			</floppy>
			<parallel_port>
				<port_type type="integer">0</port_type>
			</parallel_port>
			<serial_port>
				<connect_immediately type="boolean">false</connect_immediately>
			</serial_port>
		</super_io>
	</hardware>
	<integration>
		<microsoft>
			<folder_sharing>
				<enabled type="boolean">false</enabled>
				<load_allowed type="boolean">false</load_allowed>
			</folder_sharing>
			<heartbeat>
				<failure_attempts type="integer">12</failure_attempts>
				<failure_interval type="integer">10</failure_interval>
				<rate type="integer">10</rate>
				<time type="integer">60</time>
			</heartbeat>
			<host_time_sync>
				<enabled type="boolean">true</enabled>
				<frequency type="integer">15</frequency>
				<threshold type="integer">10</threshold>
			</host_time_sync>
			<mouse>
				<allow type="boolean">true</allow>
			</mouse>
			<version>
				<additions_number type="string" />
				<guest_os>
					<build_number type="string" />
					<computer_name type="string" />
					<long_name type="string" />
					<revision_number type="string" />
					<short_name type="string" />
					<suite_name type="string" />
				</guest_os>
			</version>
			<video>
				<user_selected>
					<depth type="integer">16</depth>
					<height type="integer">480</height>
					<width type="integer">640</width>
				</user_selected>
			</video>
		</microsoft>
	</integration>
	<properties>
		<creator>
			<build type="string">6.1.7601.17514</build>
			<name type="string">Virtual PC</name>
		</creator>
		<modifier>
			<build type="string">6.1.7601.17514</build>
			<name type="string">Virtual PC</name>
		</modifier>
	</properties>
	<settings>
		<configuration>
			<next_id type="integer">1</next_id>
			<saved_state>
				<path>
					<absolute type="string" />
					<relative type="string" />
				</path>
			</saved_state>
		</configuration>
		<disks>
			<track_disk_cache>
				<enabled type="boolean">true</enabled>
			</track_disk_cache>
		</disks>
		<globalconfigid type="string">{C590611A-AD1C-4077-B150-B03EE2901C8F}</globalconfigid>
		<host>
			<resource_control>
				<cpu>
					<host_processors type="integer">1</host_processors>
				</cpu>
			</resource_control>
		</host>
		<notes type="string" />
		<shutdown>
			<quit>
				<action type="integer">0</action>
			</quit>
		</shutdown>
		<sound>
			<sound_adapter>
				<enable type="boolean">true</enable>
			</sound_adapter>
		</sound>
		<undo_drives>
			<always type="boolean">false</always>
			<default_action type="integer">1</default_action>
			<enabled type="boolean">false</enabled>
			<purposely_kept type="boolean">false</purposely_kept>
			<use_default type="boolean">true</use_default>
		</undo_drives>
		<video>
			<enhanced_mode type="boolean">false</enhanced_mode>
			<full_screen type="boolean">false</full_screen>
		</video>
	</settings>
	<virtual_machines>
		<allow_packet_filtering type="boolean">false</allow_packet_filtering>
		<allow_promiscuous_mode type="boolean">false</allow_promiscuous_mode>
	</virtual_machines>
	<multi_channel type="boolean">true</multi_channel>
	<ui_options>
		<window_xpos type="integer">491</window_xpos>
		<window_ypos type="integer">182</window_ypos>
		<full_screen type="boolean">false</full_screen>
		<resolution_height type="integer">768</resolution_height>
		<resolution_width type="integer">1024</resolution_width>
	</ui_options>
</preferences>

Open in new window


When the VM boots there are two errors then it goes to black screen and says you have to shut-down the VM.
Error 1Error 2
0
 
JohnBusiness Consultant (Owner)Commented:
The configuration file does not contain the integration features greyed out.

Try starting the VM in Safe Mode.  Press F8 in the machine window as it starts.  There is an error in the machine itself.
0
 
PAMurilloAuthor Commented:
I am combing through and trying to delete all VM settings. I cannot delete a folder or the contents of: C:\Program Files (x86)\Windows Virtual PC\Integration Components. It says I need to get permission from Trusted Installer. I tried changing permission to Administrators or even as the User but no luck. Any suggestions/TrustedInstaller error
0
 
JohnBusiness Consultant (Owner)Commented:
Trusted Installer is part of Windows and cannot normally be used.

1. Did you try starting the XP Machine in Safe Mode?  (XP Machine Error above)

2. Did you try uninstalling / installing XP Mode?  (XP Mode Integration errors)
0
 
PAMurilloAuthor Commented:
Hi John Hurst,
I tried starting the XP VM in Safe Mode. I got the same 2 errors followed by the black screen and notification that I had to shut down the VM
I tried uninstalling XP mode, rebooting the host computer into Safe Mode to try to remove the Integration Components folder but I still couldn't delete the folder or its contents for the same Trusted Installer locking it. I renamed the parent folder Windows Virtual PC to Windows Virtual PC  Old and reinstalled XP mode, Created a new VM - no problem
Created a new VM using the old VM folder and got the same errors

I may have to dig-up a WinXP Machine and throw the VM backup on it.

Any other suggestions?
0
 
JohnBusiness Consultant (Owner)Commented:
OK, thanks. I think the machine is damaged and at this point you need to re-create the XP machine either from scratch or by converting an existing machine.

If you have an XP CD at the same SP level as the machine (may be unlikely) you could try doing a Repair. You would have to boot from the CD inside the VM to make this happen.
0
 
PAMurilloAuthor Commented:
The VM file was corrupted even after running the Merge function. My solution was to:
1) Create a new Windows XP VM
2) Using Carbonite which I had installed when originally creating the VM on the VM itself, I was able to recover the needed files on the VM
3) Transferred the files to the new VM and setup new
0
 
JohnBusiness Consultant (Owner)Commented:
Thanks for the update and I was happy to help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 9
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now