HP Laserjet - 2300dtn - HP Pavillion DV7 running Windows 7 Home Premium - Can't Print

I purchased a used DV7 to replace my battered DV7 but I can't get the printer to print.   Driver is installed and is reported to be working properly.  On my old DV7, I kept getting additional HP2300 printers to install, so I would get a copy 1, copy 2 and copy 3 printers and would have to hit and miss on which one was the proper printer to use.  I have tried removing all the drivers and even went into cmd.exe to delete any drivers (can't recall exacty what I was supposed to do), but I could not get into the authorization level needed.  Also, all my USB plug ins seem to be working properly.
jorbay-DallasTexasAsked:
Who is Participating?
 
JohnBusiness Consultant (Owner)Commented:
You may need to do a Windows 7 Repair Install from the Windows 7 DVD if something in the OS is screwed up.
1
 
hdhondtCommented:
On the new DV7, what happens when you try to print? Any error messages on either the PC or the printer? Does the printer indicate it is receiving data (with a flashing light)? Did you install the driver or was it pre-installed? In the latter case, as you implied you are using a USB connection, it probably will not work.
0
 
jorbay-DallasTexasAuthor Commented:
When I try to print, it shows up in the Print Queue.  No error messages, no flashing lights on printer indicating transfer.  I removed all the drivers and reinstalled.  Printers are a puzzle to me.  I am an old LPT1 Guy.  It seems like they should get simpler.  I also have a Brothers MFP-8890-DW that is also a problem.  I prefer my HP Printer and I also have an HP-3, but I would have to do a USB to Serial connection.
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
JohnBusiness Consultant (Owner)Commented:
HP has 2 different drivers for Windows 7 on this page:

https://support.hp.com/ca-en/drivers/selfservice/hp-laserjet-2300-printer-series/238800

I would try the newer one (2017) 6.5.0.22695

Clear the Print Spooler:
Right-click “Command Prompt” and select “Run as administrator“.
Type net stop spooler then press “Enter“.
Type del %systemroot%\System32\spool\printers\* /Q then press “Enter“.
Type net start spooler then press “Enter“

Remove the printer from Devices and Printers.
Click once on any other printer to show the Printer Server Management Menu.
Open the Drivers tab and delete any / all H2300 drivers.

Now restart and try installing the package above.
0
 
hdhondtCommented:
I removed all the drivers and reinstalled
I don't know what you did, so just in case... Just deleting the printer is not enough. Do the following. In Devices and Printers, first delete the printer. Then click on any other printer driver, and select "Print Server Properties" from the menu that appears. Click the Drivers tab and remove every entry for your printer from the list. Reboot, just to make sure, and reinstall the printer.

To reinstall, first download a driver from John's link. PLC5 or PCL6 would be the preferred type. Run the downloaded .exe file and remember where the driver files are placed. Now plug the printer in and switch it on. When Windows looks for the drivers, point it at the location of the driver files.

I will add that I prefer to use a network connection for printers; that usually gives less trouble than USB. If you want to do that, plug it into your router/switch, give it an IP address (either on its front panel or via a reservation on the router). Then install it as a local printer. When asked for the port, type in the printer's IP address.
0
 
nobusCommented:
for usb printers, follow this :
after uninstalling all printers and their software, disconnect the printer
Now install the software, and only connect the printer when asked for !
0
 
micheal johnPrinter Support ExpertCommented:
Hai,
   In My knowledge that is a Driver Related issue So, You need to Re-install the Driver.Then the Issue will be fixed. Again  the Problem will Continue just follow this link: https://h30434.www3.hp.com/t5/LaserJet-Printing/Printer-will-not-print-multiple-copies-with-windows-10/td-p/5959991
It will Support you.
0
 
jorbay-DallasTexasAuthor Commented:
Thanks to everyone!

I have read and followed as many of your suggestions as possible.  

The run Admin issue regarding clear spooler was what I was speaking about originally where I couldn't get into Admin, So, thank you John for the instructions and the HP Link which I had found previously.  hdhondt, I followed your instruction about going to the Print Administrator (it took me a will to find the "Tab" at the top of the page, I looked in the drop down options.  Anyway, I eliminated all the references to any and all printers that I could, but, I still could not get it to work.  I figured that the plug and play should ask me for the location of the driver, but it didn't so I clicked on the driver.  See attached, the photo secquence is by a tally mark at the end of the file name.
HP-Printer-issues111111.JPG
0
 
JohnBusiness Consultant (Owner)Commented:
The run Admin issue regarding clear spooler was what I was speaking about originally where I couldn't get into Admin

Thanks for this. I did not interpret your first post correctly.

Are you saying you still cannot run Administrative commands?  This will prevent the printer from installing.
0
 
nobusCommented:
did you disconnect the printer -as asked ?
0
 
jorbay-DallasTexasAuthor Commented:
OK, I posted the screen shot,  It showed that I cleared the Spooler.

Second, I did disconnect the printer and then plugged in as directed and a notification popped up and then disappeared and I tried to use the notice for plug and play but it appeared to have nothing to do with the USB or Printer?  I then clicked ton the driver file which I downloaded and I installed the driver which was instructed.  I will try the removal and installation one more time.  Thanks  John
0
 
hdhondtCommented:
I followed your instruction about going to the Print Administrator
My instructions were to go to Devices & Printers. If you select an printer there, a menu will appear at the top that has an entry for "Print server properties". The next window that opens will have a "Drivers" tab. Then remove your printer from that list.
0
 
jorbay-DallasTexasAuthor Commented:
OK hdhondt, whatever that means, I did do exactly what you said and went to D&P, selected a different printer and went to the tab for "Print Server Properties", I am not sure why I said "Print Administrator"  And I did remove the driver.  When I tried to remove all associated files, it failed to remove them, see attached photo.  I have followed all your instructions, I removed all the references to any and All HP 2300,  I cleared the spooler, I went ahead and unpacked the zip file for the printers and tried to direct the instruction to the driver, and it indicated that it was successfully installed, but it still wouldn't print.    I then let it do a Plug and Play installation, but it still wouldn't print.   Before I did all the above for a second time, I hooked up my old HP DV7 and printed a page with no problems except for the P&D added a second copy of the HP2300 (very annoying) that I had to use instead of the first one.  Why oh Why is Windows 7 so screwed up, or is it ME?  I am very annoyed now and I don't want to take it out on anyone, but I am just frustrated.  I used to be pretty good at this in the early 1990, lol.   You can call me John
AAA-HP-PRINTER-111111.JPG
0
 
hdhondtCommented:
Does your login have admin privileges? If it doesn't, try logging in as administrator and then see if you can uninstall and re-install.
1
 
jorbay-DallasTexasAuthor Commented:
OK, thank you John and hdhondt.  

John, I am getting to the point of agreeing with you on a reinstall or repair.  HP started putting the back up on the harddrive which perplexes me.  I do have a disk that was burned by the seller of the laptop when I bought it, but I haven't tried anything with it. (I need to find it)

Hdhondt, I checked the administrator account and there is no password,  
I did find a file for Administrative Tools, which I have never really had much of a need to access
It is located at Control Panel/All Control Panel Items/Adminstrative Tools

When I remove any and all drivers and references to the HP2300 printer, Windows asks if I want to delete just the driver or the package.  When I delete driver and package, the package (inf file) can't be removed as shown on one of the screen shots that I provided previously.

Anyway, I am going to be out of town for a few days and will need to get back to this later in the week.  Give it a rest for a few days.

Thanks again
0
 
Seth SimmonsSr. Systems AdministratorCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Accept: John Hurst (https:#a42441478)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

seth2740
Experts-Exchange Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.