• Status: Solved
  • Priority: High
  • Security: Public
  • Views: 91
  • Last Modified:

After a yum update, I can no longer open a port...

We recently performed a yum update on the RHEL7 box, and much to our dismay, the ability to open the port now fails.

There are two scripts we have to run in order to open the port:
This one runs:
sudo iptables -A INPUT -p tcp --dport 1234 -j ACCEPT

This one fails:
sudo iptables -A IN_public_allow -p tcp -m tcp --dport 1234 -m conntrack --ctstate NEW -j ACCEPT

Gives the following error:
iptables: No chain/target/match by that name.

This always worked for years, now that latest update won't allow this to run

Any help would be greatly appreciated.

Thanks
0
cyimxtck
Asked:
cyimxtck
  • 2
1 Solution
 
Jan SpringerCommented:
iptables --list -n --line-numbers

or

cat /etc/sysconfig/iptables

Put "X.X" for the first two octets of public IPs/subnets.
0
 
cyimxtckAuthor Commented:
great work!
0
 
Jan SpringerCommented:
For the archives should anyone else have a problem, would you please define how this helped?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now