Booting from Samsun NVMe M.2 w/ DELL T7610 Workstation

Trying to get a DELL Precision Workstation to boot of the installed Samsung M.2 NVMe 512gb drive after installing Win10 Pro. The install goes fine form a USB drive generated with MediaCreator and booted as UEFI device. It sees the Samsung disk and completes the setup without errors, but the system will find drive or start after initial reboot (USB removed).

Here is what I have done:

- Updated to latest BIOS
- Enable UEFI mode
- Enabled and Disabled Legacy options
- Enabled and Disabled SATA ACHI and LSI RAID

The BIOS does show a Mass Storage Device in PCI Slot 1.

After install the Boot Sequence specifies Windows Boot Manager.

We have reviewed other threads here as well as DELL's link - http://www.dell.com/support/article/us/en/04/sln300820/what-are-pcie-ssds-and-how-to-use-them-as-a-b...

Nothing seems to work, and I am hoping some has an idea.

I have included some screens below.

Win Install1
Win Install2
Win Install3
Reboot
Boot Sequence
Bios
zicemanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jackie ManCommented:
Have you updated the BIOS?

https://downloads.dell.com/FOLDER04755868M/1/T7610A15.exe

How did you connect the NVMe to the motherboard?

Are your SSD in the list below?

KTM9M 256GB Micron

HHCWG 512GB Liteon M3S-M
2XFM1 512GB Liteon M6S-T
HN71H 512GB Liteon M9S
3YYV3 256GB Liteon L9S
DFVVG 256GB LiteOn Vangogh
X9HG1 256GB Liteon Vangogh
WKFTG 256GB LiteOn Vangogh
XFJWX 256GB Liteon M6S
W18WD 128GB Liteon Vangogh

P4GHK 512GB Samsung SM841
V622H 256GB Samsung PM830
YRK2P 256GB Samsung SM841N
FFKNK 256GB Samsung PM841

Source: https://www.dell.com/community/Desktops-General/T7600-NVMe-supported/m-p/5006808#M1008229
0
zicemanAuthor Commented:
Yes, as indicated in my post. The BIOS was updated. It is dated 01/10/2018.

That list is not really applicable. Most of the drives on it ( like the P4GHK 512GB Samsung SM841) are SSD SATA, not NVMe.

The drive is connected to the mainboard with a PCIe adapter card. There does not appear to be any issue with the the machine seeing the drive itself. It is listed in the BIOS as a Mass Storage Device in PCI slot 1, and the Win10 installer detects, formats and completes setup. Just won't boot.
0
Jackie ManCommented:
Give details of the PCIe adapter card.

Not all PCIe adapter card can be functioned as a boot device.

It is a known issue of incompatibilities of NVMe SSD with PCIe adapter card.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

zicemanAuthor Commented:
Will need to check the brand / model, but the same PCIe adapter card is working OK booting with the identical Samsung Nvme ssd drive on two HP Z440 workstations.
0
Jackie ManCommented:
You need to use Mmtool to insert the NVMe module. Your BIOS does not support direct boot from NVMe via PCIe adapter card without BIOS modification.

Source: https://www.dell.com/community/Desktops-General/PCIe-device-boot/td-p/5029343/page/4
0
Rob KnightConsultantCommented:
This is not possible as the T7610 pre-dates NVMe M2 drives and since the product is EOL, BIOS support is unlikely.

An SSD on SATA should work, however.

You.may find an NVMe to SATA adapter would work too.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
Lately, I install a Dell Precision T7910 with sata drives and win10 v1709 and it showed the strangest effects when installed as UEFI. All drivers and the bios were up 2 date. Since it did not matter to us, we abandoned the search for causes after some hours and installed it non-UEFI and everything works ever since.

If it does not matter to use UEFI, please install in non-UEFI mode.
0
zicemanAuthor Commented:
@RobMobility - are you certain that it simply does not work?  DELL's link above seems to imply that it is supported, and the BIOS update installed was less than two weeks old. I am inclined to agree with you, but I need a definitive answer for my client.

@McKnife - I have tried switching out of UEFI mode, but then it just says "no hard drives detected". In the BIOS listing, however, a Mass Storage Device is indeed shown in PCI slot 1. But I cannot pick this from the boot sequence.
0
McKnifeCommented:
You misunderstood. You require a reinstallation.
1 switch to legacy booting and non-uefi
2 install windows clean from a USB bootable stick that was not booted as uefi but legacy
...there will be hard drives seen.
0
zicemanAuthor Commented:
OK. I will double-check and post back. I had thought the installer was not seeing the NVMe disk in non-UEFI mode.
0
Jackie ManCommented:
"DELL's link above seems to imply that it is supported"

Which link?
0
Jackie ManCommented:
Your link is only an article about general information on how PCIe SSD is supported.

Compatible BiOS is a critical deciding factor if you want to use PCIe NVMe. You need specific information for your model of computer.
0
zicemanAuthor Commented:
OK. But there does not appear to be a list of NVMe drives that I find. The one you provided was SATA.
0
nobusCommented:
you still did not pot the model of the pcie card
0
zicemanAuthor Commented:
Here is the adapter card info - Mailiya M.2 PCIe to PCIe 3.0 x4 Adapter - Support M.2 PCIe 2280, 2260, 2242, 2230 (http://a.co/dQjVX1M)

The same card and Samsung PVMe drive combination is working fine in two HP Z440 workstations at the client location. Also, the DELL-T7610 with the latest BIOS is detecting the card, showing a Mass Storage device at PCI Slot one and successfully completing and Win10 Pro setup to the drive right up to the prompt to reboot.
0
Jackie ManCommented:
It is a known issue for your Dell workstation.

HP Z440 workstations do have BIOS support for booting from NVMe device connected by PCIe whereas there is no BIOS support from Dell one.
0
zicemanAuthor Commented:
OK. Maybe I can approach this from a more basic angle...

The customer here is a CAD shop that is trying to squeeze every bit of performance out of there existing hardware. The AutoDesk engineer recommended they switch from running the Windows OS on SATA SSDs to PCI NVMe SSDs. This has worked on fine for the HP Z440 machines, but not this DELL T7610. Is

it possible to use a different drive (perhaps USB?) to kick off the boot process and then redirect the OS still run from M2 drive? Not sure this capability is in the latest Windows Boot Mgr or it is just a stupid question. 
0
Jackie ManCommented:
  1. Make sure in the BIOS that you are still set to use SATA RAID (not AHCI)
  2. Make sure that you only have the m.2 disk installed.  The other disk are disconnected
  3. Go download the driver Intel® Rapid Storage Technology and put it on an USB (you will need this later)
  4. Install windows 10 as normal
  5. When you get to the screen to select your disk nothing will be available
  6. Plug the USB with the RST driver
  7. Click on load drivers and find the RST driver on USB
  8. Disk will now appear.
  9. Proceed as normal here on out

Source: https://www.dell.com/community/Desktops-General/Can-XPS-8920-boot-from-M-2-NVMe/m-p/5151577
0
zicemanAuthor Commented:
Jackie Man - thanks. I have seen that process posted before.

May give it a shot, but I believe the mainboard and chipset for the XPS (Consumer line) models are very different from the Precision (Business / Engineering ) machines. I have seen the Intel RST running on the XPS PCs, but I cannot find it loaded on the current Precision T7610 running Win7Pro.  So, I am not very confident it is going to work.
0
zicemanAuthor Commented:
I am fairly certain now that  booting with NVMe is just not going to work. Also found this link which seems very convincing:
https://www.dell.com/community/Desktops-General/T7600-NVMe-supported/td-p/5006807/page/2

So I go back to my followup question. Since the M2 drive is detected at working, is there any way to leverage the enhanced speed in a "hybrid" situation. In other words, can we setup the boot to a standard SATA SSD while still installed most of the WIn10 PRO OS on the NVMe drive?
0
nobusCommented:
i had just an ASUS system with such a problem - it only needed the IRST enabled in the bios
did you check your bios does not have a setting ?
0
zicemanAuthor Commented:
I do not believe the DELL Precision Workstations like the T7610 has the Intel Rapid Storage Technology. Ironically, the consumer XPS units do have this, and they are able to boot from NVMe.
0
zicemanAuthor Commented:
Well, this unfortunate.

I will check with Autodesk to see if there is still any way to leverage the addition speed of the installed M.2 drive without booting from it. Maybe there is a working / cache folder that could be relocated there.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.