RDP on Windows 2012 R2 -- unable to establish a connection ?

How can I RDP into my below VM ?

Steps I did
 1. logged into PHYSICAL server
 2. used "Hyper-V Manager" to reboot Windows 2012 R2 VM
      ** open DOS prompt
      ** type "qwinsta" to make sure no other users are logged in
 3. made sure "Remote Desktop Services" and other SERVICES started
 4. retested RDP by IP address (to avoid a DNS issue)
      ** made sure I could PING the above IP address
 5. still failed with GENERIC "unable to establish a connection" error
 6. made sure VM still had "Remote Management" and "Remote Desktop" ENABLED
 7. rebooted my PC
 8. did above #2-#6 again
 9. still failed
10. made sure I can still connect to other VMs on the same PHYSICAL server
========================================
I also did the below, rebooted, and still have the same issue

Enable Multiple RDP Sessions
 1.Log into the server using Remote Desktop.
 2.Open the start screen (press the Windows key) and type gpedit.msc and open it
 3.Go to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections.
 4.Set Restrict Remote Desktop Services user to a single Remote Desktop Services session to Disabled.
 5.Double click Limit number of connections and set the RD Maximum Connections allowed to 999999.
finance_teacherAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Michael MachieIT SupervisorCommented:
Two things i do not see in your steps.  

1:
Verify the user has rights to rdp to that server by being in the remote desktop users group. Either the specific domain or local logon account or a group that includes the User in question needs to be allowed permission to RDP to it.
- an option to 'assign users' should be visible in the screen where RDP is activated
- alternatively, access "computer management -> local users and groups -> groups -> remote desktop" and add the user account there.

2:
Verify either the Firewall is turned off for the zone that matches the logon account or has an exception for your RDP port [default is port 3389]. You can validate whether or not this is the issue quickly by disabling windows firewall on the server entirely and reconnecting via rdp. If connection succeeds it is a firewall issue.

You may want to disable the firewall first because one or the other of the two above could still block access. Whether or not the user is added to the RDP group on the server the Firewall could still block rdp sessions if it is enabled without an exception for the rdp port.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
finance_teacherAuthor Commented:
Attached was causing my issue
s1095.jpg
0
Michael MachieIT SupervisorCommented:
Totally explains it!

Also, watch out for the firewall being re-enabled after windows updates apply, sometimes even after simple reboots.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.